Modify

Opened 5 years ago

Closed 5 years ago

#12549 closed defect (fixed)

button hotplug events are not triggered (r34432 wzr-hp-g300nh)

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

Pressing wzr-hp-g300nh hardware buttons (wps, usb eject) does not trigger hotplug events anymore.

Attachments (0)

Change History (8)

comment:1 follow-up: Changed 5 years ago by jow

  • Priority changed from normal to response-needed

OpenWrt version? Flashed image? Installed packages?

comment:2 Changed 5 years ago by anonymous

The affected OpenWrt version was built from trunk r34432 after running dirclean
I flashed the squashfs image.

hotplug2 - 1.0-beta-4
kmod-gpio-button-hotplug - 3.6.8-1
wpad-mini - 20120910-1

A freshly built r34222 correctly trigger hardware button events.

comment:3 follow-up: Changed 5 years ago by anonymous

Issue ought to be in patches between r34315 and r34314 changesets

r34314 triggers hardware button events as well.

hotplug events were confirmed by means of custom /etc/hotplug.d/button/00-button

[ "$ACTION" = "released" ] && logger -p user.info "$BUTTON $ACTION: $SEEN"

trunk setup

make dirclean
svn up  --revision 34314
scripts/feeds update -a
scripts/feeds install -a
make oldconfig

comment:4 in reply to: ↑ 3 Changed 5 years ago by anonymous

Replying to anonymous:

Issue ought to be in patches between r34315 and r34314 changesets

Sorry I mistyped.

r34314 triggers hardware button events as well.
Issue ought to be caused by a changeset between r34315 and r34322

comment:5 Changed 5 years ago by anonymous

Issue appears to be caused by changeset r34414 "ar71xx: switch to 3.6.8"

comment:6 in reply to: ↑ 1 Changed 5 years ago by anonymous

Replying to jow:

OpenWrt version? Flashed image? Installed packages?

I tested the latest Bleeding Edge, r34812 trunk snapshot dated 21 dec
image: openwrt-ar71xx-generic-wzr-hp-g300nh-squashfs-sysupgrade.bin

hardware button events are not triggered in this version as well.

I noticed the the following error in syslog, perhaps it is related to the issue

Jan  1 01:02:31 OpenWrt kern.err kernel: [  148.900000] gpio-keys-polled gpio-keys-polled: unable to claim gpio 33, err=-517
Jan  1 01:02:31 OpenWrt kern.info kernel: [  148.910000] platform gpio-keys-polled: Driver gpio-keys-polled requests probe deferral

no additional packages were installed:

# opkg list-installed
base-files - 122-r34812
busybox - 1.19.4-5
dnsmasq - 2.62-2
dropbear - 2012.55-2
firewall - 2-55
hotplug2 - 1.0-beta-4
iptables - 1.4.10-4
iw - 3.6-1
jshn - 2012-12-18-4d0a00c82c77a9395c992841237e2c06c4606a5e
kernel - 3.6.11-1-1617a77a415647fe90df6e71bda57d90
kmod-ath - 3.6.11+2012-12-06-1
kmod-ath9k - 3.6.11+2012-12-06-1
kmod-ath9k-common - 3.6.11+2012-12-06-1
kmod-cfg80211 - 3.6.11+2012-12-06-1
kmod-crypto-aes - 3.6.11-1
kmod-crypto-arc4 - 3.6.11-1
kmod-crypto-core - 3.6.11-1
kmod-crypto-hash - 3.6.11-1
kmod-crypto-manager - 3.6.11-1
kmod-gpio-button-hotplug - 3.6.11-1
kmod-ipt-conntrack - 3.6.11-1
kmod-ipt-core - 3.6.11-1
kmod-ipt-nat - 3.6.11-1
kmod-ipt-nathelper - 3.6.11-1
kmod-leds-gpio - 3.6.11-1
kmod-ledtrig-default-on - 3.6.11-1
kmod-ledtrig-netdev - 3.6.11-1
kmod-ledtrig-timer - 3.6.11-1
kmod-ledtrig-usbdev - 3.6.11-1
kmod-lib-crc-ccitt - 3.6.11-1
kmod-mac80211 - 3.6.11+2012-12-06-1
kmod-nls-base - 3.6.11-1
kmod-ppp - 3.6.11-1
kmod-pppoe - 3.6.11-1
kmod-pppox - 3.6.11-1
kmod-usb-core - 3.6.11-1
kmod-usb-ohci - 3.6.11-1
kmod-usb2 - 3.6.11-1
kmod-wdt-ath79 - 3.6.11-1
libblobmsg-json - 2012-12-18-4d0a00c82c77a9395c992841237e2c06c4606a5e
libc - 0.9.33.2-1
libgcc - 4.6-linaro-1
libip4tc - 1.4.10-4
libjson - 0.9-2
libnl-tiny - 0.1-3
libubox - 2012-12-18-4d0a00c82c77a9395c992841237e2c06c4606a5e
libubus - 2012-12-15-bb856ad8a9a1e786494d01e34bbfe2b4d2134021
libuci - 2012-03-28.1-1
libxtables - 1.4.10-4
mtd - 20
netifd - 2012-12-17.1-2eca28705a27ab37ee902308af2c134c64c95e61
opkg - 618-3
ppp - 2.4.5-8
ppp-mod-pppoe - 2.4.5-8
swconfig - 10
uboot-envtools - 2012.04.01-1
ubus - 2012-12-15-bb856ad8a9a1e786494d01e34bbfe2b4d2134021
ubusd - 2012-12-15-bb856ad8a9a1e786494d01e34bbfe2b4d2134021
uci - 2012-03-28.1-1
wpad-mini - 20120910-1

comment:7 Changed 5 years ago by anonymous

It looks like 450-gpio-nxp-74hc153-gpio-chip-driver.patch for kernel 3.6 and 3.7 is probably incomplete.

please check these patches

trunk/target/linux/ar71xx/patches-3.6/450-gpio-nxp-74hc153-gpio-chip-driver.patch@33983
trunk/target/linux/ar71xx/patches-3.7/450-gpio-nxp-74hc153-gpio-chip-driver.patch@34920

and compare them with those made for kernel versions properly supporting button hotplug events:

trunk/target/linux/ar71xx/patches-2.6.39/206-nxp-74hc153-gpio-chip-driver.patch@27310
trunk/target/linux/ar71xx/patches-3.3/450-gpio-nxp-74hc153-gpio-chip-driver.patch@34410

comment:8 Changed 5 years ago by juhosg

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r35035.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.