Modify

Opened 5 years ago

Closed 5 years ago

#12539 closed defect (fixed)

gettext: undefined reference to 'lzma_XXXX@XZ_5.0

Reported by: rektide@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

Getting this same error in AR7 and BRCM63xxx. Stock configuration, with build all by default on. Please let me know what I can do to help aid in reproducing or debugging.

make[7]: Entering directory `/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/gettext-tools/libgrep'
make  all-am
make[8]: Entering directory `/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/gettext-tools/libgrep'
make[8]: Nothing to be done for `all-am'.
make[8]: Leaving directory `/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/gettext-tools/libgrep'
make[7]: Leaving directory `/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/gettext-tools/libgrep'
Making all in src
make[7]: Entering directory `/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/gettext-tools/src'
make  all-am
make[8]: Entering directory `/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/gettext-tools/src'
/bin/bash ../libtool  --tag=CC   --mode=link gcc -std=gnu99  -O2 -I/srv/bulk/rektide/openwrt-wndr/staging_dir/host/include  -L/srv/bulk/rektide/openwrt-wndr/staging_dir/host/lib -o msgcmp msgcmp-msgcmp.o msgcmp-msgl-fsearch.o libgettextsrc.la  -lm
OpenWrt-libtool: link: gcc -std=gnu99 -O2 -I/srv/bulk/rektide/openwrt-wndr/staging_dir/host/include -o .libs/msgcmp msgcmp-msgcmp.o msgcmp-msgl-fsearch.o  -L/srv/bulk/rektide/openwrt-wndr/staging_dir/host/lib ./.libs/libgettextsrc.so /srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/gettext-tools/gnulib-lib/.libs/libgettextlib.so -lxml2 -lncurses -lc -lm -Wl,-rpath -Wl,/srv/bulk/rektide/openwrt-wndr/staging_dir/host/lib
/usr/lib/gcc/x86_64-linux-gnu/4.7/../../../x86_64-linux-gnu/libxml2.so: undefined reference to `lzma_code@XZ_5.0'
/usr/lib/gcc/x86_64-linux-gnu/4.7/../../../x86_64-linux-gnu/libxml2.so: undefined reference to `lzma_auto_decoder@XZ_5.0'
/usr/lib/gcc/x86_64-linux-gnu/4.7/../../../x86_64-linux-gnu/libxml2.so: undefined reference to `lzma_end@XZ_5.0'
/usr/lib/gcc/x86_64-linux-gnu/4.7/../../../x86_64-linux-gnu/libxml2.so: undefined reference to `lzma_properties_decode@XZ_5.0'
collect2: error: ld returned 1 exit status
make[8]: *** [msgcmp] Error 1
make[8]: Leaving directory `/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/gettext-tools/src'
make[7]: *** [all] Error 2
make[7]: Leaving directory `/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/gettext-tools/src'
make[6]: *** [all-recursive] Error 1
make[6]: Leaving directory `/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/gettext-tools'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/gettext-tools'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1'
make[3]: *** [/srv/bulk/rektide/openwrt-wndr/build_dir/host/gettext-0.18.1.1/.built] Error 2
make[3]: Leaving directory `/srv/bulk/rektide/openwrt-wndr/package/libs/gettext-full'
make[2]: *** [package/libs/gettext-full/host/compile] Error 2
make[2]: Leaving directory `/srv/bulk/rektide/openwrt-wndr'
make[1]: *** [/srv/bulk/rektide/openwrt-wndr/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory `/srv/bulk/rektide/openwrt-wndr'

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by florian

This is a distribution issue, not specific Openwrt, I had the same issue with Ubuntu 12.10.

comment:2 Changed 5 years ago by rektide@…

fixed in /changeset/34400.html . thanks jow.

comment:3 follow-up: Changed 5 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 in reply to: ↑ 3 Changed 5 years ago by berniie

  • Resolution fixed deleted
  • Status changed from closed to reopened

Compiling gettext 0.18.2.1 for lantiq on fedora fc18.x86_64 the error reappeared.

comment:5 Changed 5 years ago by anonymous

Got the error because of libcroco package installed on my fedora machine. Patch below will fix the build.

diff -Naur a/package/libs/gettext-full/Makefile b/package/libs/gettext-full/Makefile
--- a/package/libs/gettext-full/Makefile        2013-06-23 10:57:08.000000000 +0200
+++ b/package/libs/gettext-full/Makefile        2013-06-23 11:01:40.123557387 +0200
@@ -50,7 +50,7 @@
        --without-emacs
 
 HOST_CONFIGURE_ARGS += \
-       --with-included-libxml
+       --with-included-libxml --without-libxml2-prefix --with-included-libcroco
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/libintl-full/include

comment:6 Changed 5 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed with r37115

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.