Modify

Opened 5 years ago

Last modified 5 years ago

#12526 new defect

Can't create LED subdirs - kmod-ledtrig-? WZR-HP-AG300H - Add to target?

Reported by: camden.lindsay+openwrt@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

root@…:/etc/init.d# cat /etc/banner | grep r3

BARRIER BREAKER (Bleeding Edge, r34303)

root@…:/etc/init.d# uname -a
Linux router01 3.3.8 #1 Thu Nov 22 22:02:08 PST 2012 mips GNU/Linux

Have this in logs on WZR-HP-AG300H

Nov 25 19:29:14 router01 user.info sysinit: setting up led ROUTER
Nov 25 19:29:14 router01 user.info sysinit: sh: write error: Invalid argument
Nov 25 19:29:14 router01 user.info sysinit: /etc/rc.common: eval: line 1: can't create /sys/class/leds/buffalo:green:router/device_name: nonexistent directory
Nov 25 19:29:14 router01 user.info sysinit: /etc/rc.common: eval: line 1: can't create /sys/class/leds/buffalo:green:router/mode: nonexistent directory
Nov 25 19:29:14 router01 user.info sysinit: setting up led USB
Nov 25 19:29:14 router01 user.info sysinit: sh: write error: Invalid argument
Nov 25 19:29:14 router01 user.info sysinit: /etc/rc.common: eval: line 1: can't create /sys/class/leds/buffalo:green:usb/device_name: nonexistent directory
Nov 25 19:29:14 router01 user.info sysinit: /etc/rc.common: eval: line 1: can't create /sys/class/leds/buffalo:green:usb/activity_interval: nonexistent directory

/ticket/8622.html indicates adding of package kmod-ledtrig-usbdev and perhaps another would be required for these options to work, however implies it probably is not being build as part of the WZR-HP-AG300H target.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by camden.lindsay+openwrt@…

Looking deeper, it appears that kmod-ledtrig-usbdev is part of the profile, if i'm looking in the right place:

dylan@BigBox /mnt/store/public/cjs/Computers_Electronics_Tools/Software/Networking/Routers/openWRT_source/trunk $ grep -A 2 WZRHPAG300H  target/linux/ar71xx/generic/profiles/buffalo.mk 
define Profile/WZRHPAG300H
        NAME:=Buffalo WZR-HP-AG300H
        PACKAGES:=kmod-usb-ohci kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
--
define Profile/WZRHPAG300H/Description
        Package set optimized for the Buffalo WZR-HP-AG300H
endef
--
$(eval $(call Profile,WZRHPAG300H))

define Profile/WZRHPG450H

Yet when I look in the packages directory after a build, i don't see it:

dylan@BigBox /mnt/store/public/cjs/Computers_Electronics_Tools/Software/Networking/Routers/openWRT_source/trunk/bin/ar71xx-uClibc/packages $ ls | grep kmod-ledtrig
kmod-ledtrig-default-on_3.3.8-1_ar71xx.ipk
kmod-ledtrig-timer_3.3.8-1_ar71xx.ipk

Am i missing something?

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.