Modify

Opened 5 years ago

Last modified 19 months ago

#12523 reopened defect

Add support for DIR-645 wireless

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Wireless is currently not working in the DIR-645.

Attachments (0)

Change History (20)

comment:1 Changed 5 years ago by anonymous

/etc/hotplug.d/firmware/10-rt*-firmware does not have an entry for reading the WiFi EEPROM for the 645 board, if this helps anyone. (The DLink sources, last I checked didn't have too much information, but the WiFi card is a RT3662)

comment:2 Changed 5 years ago by anonymous

Some news here? Registered that in the past months there is some work for RT3662/RT3883 wireless on trunk and linux wireless. Maybe with release and switch to kernel 3.10?

Appreciate your work.

comment:3 Changed 4 years ago by fonix232

Still no news?

comment:4 Changed 4 years ago by anonymous

Seems the device is with "floating in space" -status. Trunk having a basic support but no wireless chip support and requirement to compile binary by user itself.

Sad... as device is awesome.

comment:5 Changed 4 years ago by anonymous

Agree.. really sad. Hope someone can get wireless working.

comment:6 Changed 4 years ago by andrius@…

I think there were some changes in svn adding dir-645 to /etc/hotplug.d/firmware/10-rt*-firmware. Does it mean that wifi is working now?

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:8 Changed 3 years ago by anonymous

How does it look with the support for this device? Any recent changes? It would be perfect as this device is awesome.

comment:9 Changed 3 years ago by anonymous

Is there any progress on this ticket? It appears to be dead. If there is no activity on this ticket is there another ticket pertaining to the wireless subsystem of the dir-645 under openwrt?

Thank you

comment:10 Changed 3 years ago by anonymous

Just by curiousity i've tested with Chaos Calmer 15.05-rc1 (rt3883).
Wireless works pretty fine ! If you likes risks you can also have a try

comment:11 Changed 3 years ago by anonymous

Hello I can also confirm that Wireless works with Chaos Calmer 15.05-rc1 (rt3883).

comment:12 Changed 3 years ago by jogo

  • Milestone changed from Barrier Breaker 14.07 to Chaos Calmer (trunk)
  • Resolution set to fixed
  • Status changed from new to closed

Thanks for confirming.

comment:13 Changed 2 years ago by matt

Wifi unexpectedly drops out after short duration. Current revision (15.05) seems to be better but the wifi radio is highly volatile and stops allowing connections regularly. Setting frequency channel to auto prolongs uptime but failure is inevitable. Running wifi from ssl terminal does not solve the problem (radio shows as enabled but there are no signal bars and no devices can connect). Removing radio device and reading it sometimes corrects problems. Rebooting router rarely corrects the problem

comment:14 Changed 2 years ago by anonymous

So it looks like setting the operation frequency channel to auto causes the failure. I guess there is something wrong with the auto selection method. If I manually select a channel the wifi system seems to be stable

comment:15 follow-up: Changed 22 months ago by vandelsand@…

Hey. I am having an issue where my DIR-645 reverts to vanilla when I reboot or remove/reapply power. Is this a known issue? I have to reinstall everything and reconfigure after it boots. Everything works fine though, WIFI works great and all, but how do I fix this issue?

comment:16 Changed 22 months ago by anonymous

Looks like you are installing everything into RAM instead of flash.

comment:17 in reply to: ↑ 15 ; follow-up: Changed 20 months ago by anonymous

Replying to vandelsand@…:

Hey. I am having an issue where my DIR-645 reverts to vanilla when I reboot or remove/reapply power. Is this a known issue? I have to reinstall everything and reconfigure after it boots. Everything works fine though, WIFI works great and all, but how do I fix this issue?

Have you found any solution to this? Having the same issue.

comment:18 in reply to: ↑ 17 Changed 20 months ago by anonymous

Replying to anonymous:

Replying to vandelsand@…:

Hey. I am having an issue where my DIR-645 reverts to vanilla when I reboot or remove/reapply power. Is this a known issue? I have to reinstall everything and reconfigure after it boots. Everything works fine though, WIFI works great and all, but how do I fix this issue?

Have you found any solution to this? Having the same issue.

You need to run firstboot after flashing or else you are installing everything into RAM. (see /ticket/18456.html)

comment:19 Changed 19 months ago by anonymous

I tested openwrt on this device. I ran the firstrun script and all changes were persistent, no problem here. But on high load wifi reproducibly the drops. On restart, wifi most of the time doesn't turn on properly config shows wifi enabled). Disabling and re enabling usually fixes wireless, until it crashes a few hours later.

comment:20 Changed 19 months ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.