Modify

Opened 5 years ago

Closed 5 years ago

#12522 closed defect (invalid)

IP address alias not configured by UCI

Reported by: michel@… Owned by: developers
Priority: normal Milestone:
Component: base system Version: 10.03.1
Keywords: ip address alias Cc:

Description

IP address alias are there when I make uci show network but not when I do ifconfig. Seem to be related to sbin/ifup since I get following error while restarting network :
/sbin/ifup: eval: line 1: syntax error: bad substitution

Test with build 34265 abd 34300.

Exemple :

root@OpenWrt:/# ifconfig eth1.0:0
eth1.0:0 Link encap:Ethernet HWaddr 00:15:6D:C1:C9:16

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1


root@OpenWrt:/# uci show network.dynamique1
network.dynamique1=interface
network.dynamique1.ifname=eth1.0:0
network.dynamique1.proto=static
network.dynamique1.ipaddr=10.51.36.1
network.dynamique1.netmask=255.255.255.0

root@OpenWrt:/# ping 10.51.36.1
connect: Network is unreachable

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by michel@…

In case it would be important. Plateform AR71XX (Ubiquiti Routerstation Pro).

comment:2 Changed 5 years ago by michel@…

My bad. I just saw that syntax for alias changed between 10.03 and 10.03.1 (or was not accepted anymore).

Please close it.

comment:3 Changed 5 years ago by nbd

  • Resolution set to invalid
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.