Modify

Opened 5 years ago

Closed 5 years ago

#12510 closed defect (duplicate)

Despite the setting country to PL, channels 12 and 13 are disabled.

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: wireless Cc:

Description

TL-WDR4300 v1.3
BARRIER BREAKER (Bleeding Edge, r34253)

root@OpenWrt:~# wifi down
'radio1' is disabled
root@OpenWrt:~# uci set wireless.radio0.country=PL
root@OpenWrt:~# uci set wireless.radio0.channel=13
root@OpenWrt:~# uci set wireless.radio0.htmode=40-
root@OpenWrt:~# wifi up
'radio1' is disabled
Configuration file: /var/run/hostapd-phy0.conf
channel [12] (13) is disabled for use in AP mode, flags: 0x61
wlan0: IEEE 802.11 Configured channel (13) not found from the channel list of current mode (1) IEEE 802.11g
wlan0: IEEE 802.11 Hardware does not support configured channel
Could not select hw_mode and channel. (-4)
wlan0: Unable to setup interface.
Failed to start hostapd for phy0
'radio1' is disabled

[ 678.140000] cfg80211: Calling CRDA for country: PL
[ 678.150000] cfg80211: Regulatory domain changed to country: PL
[ 678.150000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 678.160000] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 678.170000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 678.170000] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 678.180000] cfg80211: (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[ 679.660000] device wlan0 entered promiscuous mode
[ 679.720000] device wlan0 left promiscuous mode
[ 679.720000] br-lan: port 2(wlan0) entered disabled state

root@OpenWrt:~# iw reg get
country PL:

(2402 - 2482 @ 40), (N/A, 20)
(5170 - 5250 @ 40), (N/A, 20)
(5250 - 5330 @ 40), (N/A, 20), DFS
(5490 - 5710 @ 40), (N/A, 27), DFS

root@OpenWrt:~# iwlist frequency
eth0.1 no frequency information.

lo no frequency information.

wlan0 11 channels in total; available frequencies :

Channel 01 : 2.412 GHz
Channel 02 : 2.417 GHz
Channel 03 : 2.422 GHz
Channel 04 : 2.427 GHz
Channel 05 : 2.432 GHz
Channel 06 : 2.437 GHz
Channel 07 : 2.442 GHz
Channel 08 : 2.447 GHz
Channel 09 : 2.452 GHz
Channel 10 : 2.457 GHz
Channel 11 : 2.462 GHz

root@OpenWrt:~# iw phy0 info
Wiphy phy0

Band 1:

Capabilities: 0x11ef

RX LDPC
HT20/HT40
SM Power Save disabled
RX HT20 SGI
RX HT40 SGI
TX STBC
RX STBC 1-stream
Max AMSDU length: 3839 bytes
DSSS/CCK HT40

Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 8 usec (0x06)
HT TX/RX MCS rate indexes supported: 0-15
Frequencies:

  • 2412 MHz [1] (20.0 dBm)
  • 2417 MHz [2] (20.0 dBm)
  • 2422 MHz [3] (20.0 dBm)
  • 2427 MHz [4] (20.0 dBm)
  • 2432 MHz [5] (20.0 dBm)
  • 2437 MHz [6] (20.0 dBm)
  • 2442 MHz [7] (20.0 dBm)
  • 2447 MHz [8] (20.0 dBm)
  • 2452 MHz [9] (20.0 dBm)
  • 2457 MHz [10] (20.0 dBm)
  • 2462 MHz [11] (20.0 dBm)
  • 2467 MHz [12] (disabled)
  • 2472 MHz [13] (disabled)
  • 2484 MHz [14] (disabled)

Bitrates (non-HT):

  • 1.0 Mbps
  • 2.0 Mbps (short preamble supported)
  • 5.5 Mbps (short preamble supported)
  • 11.0 Mbps (short preamble supported)
  • 6.0 Mbps
  • 9.0 Mbps
  • 12.0 Mbps
  • 18.0 Mbps
  • 24.0 Mbps
  • 36.0 Mbps
  • 48.0 Mbps
  • 54.0 Mbps

max # scan SSIDs: 4
max scan IEs length: 2257 bytes
Coverage class: 0 (up to 0m)
Supported Ciphers:

  • WEP40 (00-0f-ac:1)
  • WEP104 (00-0f-ac:5)
  • TKIP (00-0f-ac:2)
  • CCMP (00-0f-ac:4)
  • CMAC (00-0f-ac:6)

Available Antennas: TX 0x3 RX 0x3
Configured Antennas: TX 0x3 RX 0x3
Supported interface modes:

  • IBSS
  • managed
  • AP
  • AP/VLAN
  • WDS
  • monitor
  • mesh point
  • P2P-client
  • P2P-GO

software interface modes (can always be added):

  • AP/VLAN
  • monitor

valid interface combinations:

  • #{ managed, WDS, P2P-client } <= 2048, #{ IBSS, AP, mesh point, P2P-GO } <= 8, total <= 2048, #channels <= 1

Supported commands:

  • new_interface
  • set_interface
  • new_key
  • start_ap
  • new_station
  • new_mpath
  • set_mesh_config
  • set_bss
  • authenticate
  • associate
  • deauthenticate
  • disassociate
  • join_ibss
  • join_mesh
  • remain_on_channel
  • set_tx_bitrate_mask
  • frame
  • frame_wait_cancel
  • set_wiphy_netns
  • set_channel
  • set_wds_peer
  • tdls_mgmt
  • tdls_oper
  • probe_client
  • set_noack_map
  • register_beacons
  • Unknown command (89)
  • connect
  • disconnect

Supported TX frame types:

  • IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • mesh point: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • (null): 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0

Supported RX frame types:

  • IBSS: 0xb0 0xc0 0xd0
  • managed: 0x40 0xd0
  • AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
  • AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
  • mesh point: 0xb0 0xc0 0xd0
  • P2P-client: 0x40 0xd0
  • P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
  • (null): 0x40 0xd0

Device supports RSN-IBSS.
HT Capability overrides:

  • MCS: ff ff ff ff ff ff ff ff ff ff
  • maximum A-MSDU length
  • supported channel width
  • short GI for 40 MHz
  • max A-MPDU length exponent
  • min MPDU start spacing

Device supports TX status socket option.
Device supports HT-IBSS.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9678

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.