Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12503 closed defect (wontfix)

Installing ruby

Reported by: anatanasow@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi all I was trying to get ruby installed on my Openwrt

The following is my software/hardware information:
Tp-link wl703n + usb 4G flash device
ATTITUDE ADJUSTMENT (12.09-beta, r33312)

I was able to successfully mount the flash drive in /mnt/flash and to install the following pakages on it using opkg :
libruby - 1.9.2-p0-1
ruby - 1.9.2-p0-1
ruby-core - 1.9.2-p0-1
ruby-dl - 1.9.2-p0-1
ruby-enc - 1.9.2-p0-1
ruby-erb - 1.9.2-p0-1
ruby-gems - 1.9.2-p0-1
ruby-openssl - 1.9.2-p0-1
ruby-webrick - 1.9.2-p0-1
ruby-yaml - 1.9.2-p0-1
ruby-zlib - 1.9.2-p0-1

The problem came when I went to /mnt/flash/usr/bin and tried to run ruby:
root@OpenWrt:/mnt/flash/usr/bin# ./ruby -v
./ruby: can't load library 'libruby.so.1.9

Has enybody encountered that problem and do you know how to fix it.
I'll provided any needed informaiton.
Thanks in advance!

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

We do not support putting packages into alternative install locations.

comment:2 Changed 5 years ago by anonymous

Use extroot!!

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.