Modify

Opened 5 years ago

#12492 new defect

dockstar u-boot makes bricks when used according to wiki

Reported by: nop@… Owned by: developers
Priority: high Milestone:
Component: base system Version: Attitude Adjustment 12.09 Beta
Keywords: Cc:

Description

I'm not sure whether this is a documentation bug or a u-boot bug, and until I can build a mini-jtag connector I won't know. My working dockstar is offsite.

toh/seagate/dockstar includes directions for flashing u-boot to the Dockstar either as a second-stage loader or as a replacement for the existing bootloader. The instructions are obviously incorrect, since they only flash 0x40000 bytes of a 0x60000 byte image. But even correcting the size, they do not boot as a second-stage loader and bricked mine as a first stage.

The wiki appears to be cloned from post forum.openwrt.org /viewtopic.php?pid=112709 , which describes how this used to be done with the old u-boot, and probably used to be correct. In June, a new u-boot was merged (see https://lists.openwrt.org/pipermail/openwrt-devel/2012-June/015601.html ) and that post appears to be all the documentation there is. Of course I didn't find it until after the brick. :-)

Strongly suggest somebody with a working dockstar follow some set of directions before release....

Adding to confusion, it's not clear to me what the difference between the bin/ .kwb and .img files are. I *suspect* the .kwb should be usable anywhere .img is (but not vice versa).

Attachments (0)

Change History (0)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.