Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12478 closed defect (worksforme)

TL-WR841ND, A.A. beta2, wireless domain SE:, br-0 does not bridge IPV6

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

kmod-ipv6 istalled, routers will not inherit lan addresses emitted by dlink 825, though end systems (PCs etc) see global IP. Cannot configure static IPV6 prefix, since this is formed from IP4 with 6rd, so prefix may change.

Attachments (0)

Change History (10)

comment:1 Changed 5 years ago by jow

  • Resolution set to too_vague
  • Status changed from new to closed

comment:2 Changed 5 years ago by anonymous

Configuration: network behind a DIR-825, which is receiving a global IPV6 prefix, obtained via 6rd, so NOT STATIC, announces prefix on LAN A. Hosts on LAN A obtain IPV6 addresses and can access IPV6 hosts on internet. Second LAN B bridged by two TL-WR841ND, LAN A -- 841 -- WDS -- 841 -- LAN B. IPV6 prefix as advertised (by DIR-825 and seen by hosts) is NOT propagated to second LAN. 841's loaded with 12.09 beta2 image + kmod-ipv6, and works OK for IPV4, but do NOT see radvd announcement from DIR-825, (ifconfig on 841s only show local link IPV6 address ) and do not propagate IPV6. Since local eth port is *bridged* to wlan (br-0) , i.e. same L2 domain, L2 traffic SHOULD pass via WDS bridge.

comment:3 Changed 5 years ago by anonymous

  • Resolution too_vague deleted
  • Status changed from closed to reopened

comment:4 Changed 5 years ago by anonymous

Closer examination of a packet emitted on the A LAN and the result after WDS onto LAN B shows that the br-0 does NOT bridge IPV6 routing advertisments. The OpenWrt bridging/routing code zeroes the router lifetime field, AND corrects the checksum before forwarding the packet. It does not change the source or dst fields, fe80 xxxxxxxxxxxx 57 -> fe02::01
86 00 89b4 40 40 0708 00000000 00000000 original packet
86 00 90bc 40 40 0000 00000000 00000000 liftime zeroed, chksum changed

This is probably the reason bridging of IPV6 does not work.

Regards,
gweb

comment:5 Changed 5 years ago by anonymous

Clarification: "does NOT bridge" means does something *between* route and bridge in that it bridges BUT also modifies someone elses routing advertisment packet.

comment:6 Changed 5 years ago by anonymous

With just the base image including web interface, but >without< kmod-ipv6 it *looks* like routing adverts are forwarded correctly over the bridge, and routing tables on linux systems on both sides look correct. However, tracerouting does not work and IPV6 traffic is not forwarded over WDS.

comment:7 Changed 5 years ago by anonymous

More analysis shows that the neighbor solicitation is broken IF using the linux bridging code.
Consider a L2 domain formed from a 4-port switch and a Wifi interface called "LAN". Neighbor solicitation works between ports 1-4, but not between these and port 5 (wifi). The cause is that multicast forwarding is blocked in the linux bridge code, but not in the HW. This seems to be a kernel/ipv6 issue rather than Openwrt specific. It should be relatively simple to test with any Linux distribution, two ethernet interfaces and bridge kernel module.

comment:8 Changed 5 years ago by Gulweb

Also tested on A.A.rc1, but only tested client access via openwrt IPV6. IPV6 works OK from the router, and from the LAN, but not from a client connected via Openwrt wireless.

comment:9 Changed 5 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

works in current versions

comment:10 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.