Modify

Opened 5 years ago

Closed 5 years ago

#12462 closed defect (not_a_bug)

TL-WDR4300 Tx-Power is smaller then the option txpower and the max EIRP.

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: ath9k wifi txpower Cc:

Description

r34122
TL-WDR4300 v1.3

root@OpenWrt:~# iw phy0 info
Wiphy phy0

Band 1:

Capabilities: 0x11ef

RX LDPC
HT20/HT40
SM Power Save disabled
RX HT20 SGI
RX HT40 SGI
TX STBC
RX STBC 1-stream
Max AMSDU length: 3839 bytes
DSSS/CCK HT40

Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 8 usec (0x06)
HT TX/RX MCS rate indexes supported: 0-15
Frequencies:

  • 2412 MHz [1] (27.0 dBm)
  • 2417 MHz [2] (27.0 dBm)
  • 2422 MHz [3] (27.0 dBm)
  • 2427 MHz [4] (27.0 dBm)
  • 2432 MHz [5] (27.0 dBm)
  • 2437 MHz [6] (27.0 dBm)
  • 2442 MHz [7] (27.0 dBm)
  • 2447 MHz [8] (27.0 dBm)
  • 2452 MHz [9] (27.0 dBm)
  • 2457 MHz [10] (27.0 dBm)
  • 2462 MHz [11] (27.0 dBm)
  • 2467 MHz [12] (disabled)
  • 2472 MHz [13] (disabled)
  • 2484 MHz [14] (disabled)

Bitrates (non-HT):

  • 1.0 Mbps
  • 2.0 Mbps (short preamble supported)
  • 5.5 Mbps (short preamble supported)
  • 11.0 Mbps (short preamble supported)
  • 6.0 Mbps
  • 9.0 Mbps
  • 12.0 Mbps
  • 18.0 Mbps
  • 24.0 Mbps
  • 36.0 Mbps
  • 48.0 Mbps
  • 54.0 Mbps

max # scan SSIDs: 4
max scan IEs length: 2257 bytes
Coverage class: 0 (up to 0m)
Supported Ciphers:

  • WEP40 (00-0f-ac:1)
  • WEP104 (00-0f-ac:5)
  • TKIP (00-0f-ac:2)
  • CCMP (00-0f-ac:4)
  • CMAC (00-0f-ac:6)

Available Antennas: TX 0x3 RX 0x3
Configured Antennas: TX 0x3 RX 0x3
Supported interface modes:

  • IBSS
  • managed
  • AP
  • AP/VLAN
  • WDS
  • monitor
  • mesh point
  • P2P-client
  • P2P-GO

software interface modes (can always be added):

  • AP/VLAN
  • monitor

valid interface combinations:

  • #{ managed, WDS, P2P-client } <= 2048, #{ IBSS, AP, mesh point, P2P-GO } <= 8, total <= 2048, #channels <= 1

Supported commands:

  • new_interface
  • set_interface
  • new_key
  • start_ap
  • new_station
  • new_mpath
  • set_mesh_config
  • set_bss
  • authenticate
  • associate
  • deauthenticate
  • disassociate
  • join_ibss
  • join_mesh
  • remain_on_channel
  • set_tx_bitrate_mask
  • frame
  • frame_wait_cancel
  • set_wiphy_netns
  • set_channel
  • set_wds_peer
  • tdls_mgmt
  • tdls_oper
  • probe_client
  • set_noack_map
  • register_beacons
  • Unknown command (89)
  • connect
  • disconnect

Supported TX frame types:

  • IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • mesh point: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
  • (null): 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0

Supported RX frame types:

  • IBSS: 0xb0 0xc0 0xd0
  • managed: 0x40 0xd0
  • AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
  • AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
  • mesh point: 0xb0 0xc0 0xd0
  • P2P-client: 0x40 0xd0
  • P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
  • (null): 0x40 0xd0

Device supports RSN-IBSS.
HT Capability overrides:

  • MCS: ff ff ff ff ff ff ff ff ff ff
  • maximum A-MSDU length
  • supported channel width
  • short GI for 40 MHz
  • max A-MPDU length exponent
  • min MPDU start spacing

Device supports TX status socket option.
Device supports HT-IBSS.

root@OpenWrt:~# cat /etc/config/wireless
config wifi-device 'radio0'

option type 'mac80211'
option channel '11'
option hwmode '11ng'
option path 'platform/ar934x_wmac'
option htmode 'HT40-'
list ht_capab 'LDPC'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option noscan '1'
option country 'BO'
option txpower '27'
option disabled '0'

config wifi-iface

option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid ''
option encryption 'psk2'
option key ''

config wifi-device 'radio1'

option type 'mac80211'
option channel '36'
option hwmode '11na'
option path 'pci0000:00/0000:00:00.0'
option htmode 'HT20'
list ht_capab 'LDPC'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option disabled '1'

config wifi-iface

option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid ''
option encryption 'psk2'
option key ''

root@OpenWrt:~# iwconfig wlan0
wlan0 IEEE 802.11bgn Mode:Master Tx-Power=19 dBm

RTS thr:off Fragment thr:off
Power Management:on

There is workaround, add following commands in:
wifi down
iw reg set PL
wifi up

root@OpenWrt:~# iwconfig wlan0
wlan0 IEEE 802.11bgn Mode:Master Tx-Power=27 dBm

RTS thr:off Fragment thr:off
Power Management:on

root@OpenWrt:~# dmesg
[ 28.990000] Compat-drivers backport release: compat-drivers-2012-09-04-2-gddac993
[ 29.000000] Backport based on wireless-testing.git master-2012-09-07
[ 29.010000] compat.git: wireless-testing.git
[ 29.080000] cfg80211: Calling CRDA to update world regulatory domain
[ 29.080000] cfg80211: World regulatory domain updated:
[ 29.090000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 29.100000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 29.110000] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 29.110000] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 29.120000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 29.130000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 29.690000] ath: EEPROM regdomain: 0x0
[ 29.690000] ath: EEPROM indicates default country code should be used
[ 29.690000] ath: doing EEPROM country->regdmn map search
[ 29.690000] ath: country maps to regdmn code: 0x3a
[ 29.690000] ath: Country alpha2 being used: US
[ 29.690000] ath: Regpair used: 0x3a
[ 29.690000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 29.690000] Registered led device: ath9k-phy0
[ 29.690000] ieee80211 phy0: Atheros AR9340 Rev:0 mem=0xb8100000, irq=47
[ 29.700000] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[ 29.710000] ath: EEPROM regdomain: 0x0
[ 29.710000] ath: EEPROM indicates default country code should be used
[ 29.710000] ath: doing EEPROM country->regdmn map search
[ 29.710000] ath: country maps to regdmn code: 0x3a
[ 29.710000] ath: Country alpha2 being used: US
[ 29.710000] ath: Regpair used: 0x3a
[ 29.710000] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[ 29.710000] Registered led device: ath9k-phy1
[ 29.710000] ieee80211 phy1: Atheros AR9300 Rev:4 mem=0xb0000000, irq=40
[ 29.720000] cfg80211: Calling CRDA for country: US
[ 29.730000] cfg80211: Regulatory domain changed to country: US
[ 29.730000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 29.740000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[ 29.750000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[ 29.760000] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 29.770000] cfg80211: (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 29.770000] cfg80211: (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 29.780000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 30.030000] PPP generic driver version 2.4.2
[ 30.210000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 30.300000] NET: Registered protocol family 24
[ 30.340000] nf_conntrack version 0.5.0 (1976 buckets, 7904 max)
[ 30.620000] usbcore: registered new interface driver usbserial
[ 30.630000] USB Serial support registered for generic
[ 30.630000] usbcore: registered new interface driver usbserial_generic
[ 30.640000] usbserial: USB Serial Driver core
[ 30.690000] USB Serial support registered for GSM modem (1-port)
[ 30.700000] usbcore: registered new interface driver option
[ 30.710000] option: v0.7.2:USB Driver for GSM modems
[ 33.250000] device eth0.1 entered promiscuous mode
[ 33.250000] device eth0 entered promiscuous mode
[ 35.050000] eth0: link up (1000Mbps/Full duplex)
[ 35.070000] br-lan: port 1(eth0.1) entered forwarding state
[ 35.070000] br-lan: port 1(eth0.1) entered forwarding state
[ 35.600000] usb 1-1.1: USB disconnect, device number 3
[ 35.760000] cfg80211: Calling CRDA for country: BO
[ 35.760000] cfg80211: Regulatory domain changed to country: BO
[ 35.770000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 35.780000] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[ 35.780000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[ 37.070000] br-lan: port 1(eth0.1) entered forwarding state
[ 37.380000] device wlan0 entered promiscuous mode
[ 37.630000] br-lan: port 2(wlan0) entered forwarding state
[ 37.640000] br-lan: port 2(wlan0) entered forwarding state
[ 39.640000] br-lan: port 2(wlan0) entered forwarding state
[ 40.420000] usb 1-1.1: new high-speed USB device number 4 using ehci-platform
[ 40.690000] option 1-1.1:1.0: GSM modem (1-port) converter detected
[ 40.690000] usb 1-1.1: GSM modem (1-port) converter now attached to ttyUSB0
[ 40.700000] option 1-1.1:1.1: GSM modem (1-port) converter detected
[ 40.710000] usb 1-1.1: GSM modem (1-port) converter now attached to ttyUSB1
[ 40.720000] option 1-1.1:1.2: GSM modem (1-port) converter detected
[ 40.720000] usb 1-1.1: GSM modem (1-port) converter now attached to ttyUSB2
[ 40.740000] scsi1 : usb-storage 1-1.1:1.5
[ 40.740000] scsi2 : usb-storage 1-1.1:1.6
[ 41.740000] scsi 1:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 0
[ 41.750000] scsi 2:0:0:0: Direct-Access HUAWEI SD Storage 2.31 PQ: 0 ANSI: 2
[ 41.760000] sd 2:0:0:0: [sda] Attached SCSI removable disk
[ 46.900000] device wlan0 left promiscuous mode
[ 46.900000] br-lan: port 2(wlan0) entered disabled state
[ 47.050000] cfg80211: Calling CRDA for country: PL
[ 47.060000] cfg80211: Regulatory domain changed to country: PL
[ 47.070000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 47.080000] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 47.080000] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 47.090000] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 47.100000] cfg80211: (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[ 47.450000] cfg80211: Calling CRDA for country: BO
[ 47.460000] cfg80211: Regulatory domain changed to country: BO
[ 47.460000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 47.470000] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[ 47.480000] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (N/A, 3000 mBm)
[ 48.920000] device wlan0 entered promiscuous mode
[ 49.200000] br-lan: port 2(wlan0) entered forwarding state
[ 49.200000] br-lan: port 2(wlan0) entered forwarding state
[ 51.200000] br-lan: port 2(wlan0) entered forwarding state

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by anonymous

There is workaround, add following commands in /etc/rc.local:
wifi down
iw reg set PL
wifi up

comment:2 Changed 5 years ago by anonymous

iw reg set BO

gives you wider range

comment:3 Changed 5 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

The reported Tx power is limited to the hardware capability. Your hardware is simply not capable of doing 27 dBm, so it's showing less than that.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.