Modify

Opened 5 years ago

Closed 5 years ago

#12455 closed defect (duplicate)

Buffalo WHR-G54s stops authenticating wireless

Reported by: camden.lindsay+openwrt@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: hostapd, wifi drop Cc:

Description

Hardware:
WHR-G54s

Openwrt Version:

r33946 openwrt-brcm47xx-squashfs.trx trunk from 27 Oct 2012
[    0.000000] Linux version 3.3.8 (openwrt@huchra) (gcc version 4.6.4 20121001 (prerelease) (Linaro GCC 4.6-2012.10) ) #1 Sat Oct 27 08:37:34 PDT 2012

Description:
After several days of uptime, clients stop being able to authenticate against this router.

When this happens, the router also kicks the clients off of it.

The SSID continues being broadcast, however when a client attempts to connect, it gets no response.

a 'wifi down' followed by 'wifi' returns wireless to a working condition.

Here is the log snippet showing the deauth forced by the router. Between that time, and the wifi restart, multiple attempts were made to connect however nothing shows up in syslog

Nov 10 06:26:02 OpenWrt daemon.info hostapd: wlan0: STA 00:23:14:bc:b3:e0 WPA: group key handshake completed (RSN)
Nov 10 06:36:02 OpenWrt daemon.info hostapd: wlan0: STA 00:23:14:bc:b3:e0 WPA: group key handshake completed (RSN)
Nov 10 06:46:11 OpenWrt daemon.info hostapd: wlan0: STA 00:23:14:bc:b3:e0 IEEE 802.11: deauthenticated due to local deauth request
Nov 11 06:54:04 OpenWrt kern.info kernel: [384271.260000] device wlan0 left promiscuous mode
Nov 11 06:54:04 OpenWrt kern.info kernel: [384271.264000] br-lan: port 2(wlan0) entered disabled state
Nov 11 06:54:12 OpenWrt kern.info kernel: [384279.852000] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
Nov 11 06:54:13 OpenWrt kern.info kernel: [384280.032000] device wlan0 entered promiscuous mode
Nov 11 06:54:13 OpenWrt kern.info kernel: [384280.180000] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
Nov 11 06:54:14 OpenWrt kern.info kernel: [384281.428000] br-lan: port 2(wlan0) entered forwarding state
Nov 11 06:54:14 OpenWrt kern.info kernel: [384281.432000] br-lan: port 2(wlan0) entered forwarding state
Nov 11 06:54:16 OpenWrt kern.info kernel: [384283.436000] br-lan: port 2(wlan0) entered forwarding state
Nov 11 06:55:04 OpenWrt daemon.info hostapd: wlan0: STA 00:23:14:bc:b3:e0 IEEE 802.11: authenticated
Nov 11 06:55:04 OpenWrt daemon.info hostapd: wlan0: STA 00:23:14:bc:b3:e0 IEEE 802.11: associated (aid 1)
Nov 11 06:55:04 OpenWrt daemon.info hostapd: wlan0: STA 00:23:14:bc:b3:e0 WPA: pairwise key handshake completed (RSN)
Nov 11 07:04:14 OpenWrt daemon.info hostapd: wlan0: STA 00:23:14:bc:b3:e0 WPA: group key handshake completed (RSN)

Wifi settings:

root@OpenWrt:/etc/config# cat wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'ssb0:3'
	option disabled '0'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2+ccmp'
	option key 'replacedtexthere'
	option ssid 'HACKEDBOXWIFII'

Unsure of how to proceed troubleshooting. Please advise.

Attachments (1)

home-icon.gif (598 bytes) - added by Slavon 4 years ago.
http://amazonfinder.tumblr.com/

Download all attachments as: .zip

Change History (3)

comment:1 Changed 5 years ago by camden.lindsay+openwrt@…

It just happened again.
To aid in troubleshooting, i started hostapd manually with this command to write stdout/stderr to a log:

hostapd -ddKt -P /var/run/wifi-phy0.pid /var/run/hostapd-phy0.conf &>/tmp/wifilog.txt

Unfortunately, I think the log has nothing useful... it appears to have stopped working mid-stream of a Group Key Handshake:

root@OpenWrt:~# tail -10 /tmp/wifilog.txt 
1354407443.150115: wlan0: STA 00:26:37:76:ae:90 WPA: sending 1/2 msg of Group Key Handshake
1354407443.159827: wlan0: STA 00:23:14:bc:b3:e0 WPA: received EAPOL-Key frame (2/2 Group)
1354407443.160329: wlan0: STA 00:23:14:bc:b3:e0 WPA: group key handshake completed (RSN)
1354407443.651756: wlan0: STA 00:26:37:76:ae:90 WPA: EAPOL-Key timeout
1354407443.651982: wlan0: STA 00:26:37:76:ae:90 WPA: sending 1/2 msg of Group Key Handshake
1354407443.705650: wlan0: STA 00:26:37:76:ae:90 WPA: received EAPOL-Key frame (2/2 Group)
1354407443.706154: wlan0: STA 00:26:37:76:ae:90 WPA: group key handshake completed (RSN)
1354407444.185424: wlan0: STA 00:26:37:76:ae:90 WPA: received EAPOL-Key 2/2 Group with unexpected replay counter
1354408043.151695: wlan0: WPA rekeying GTK
1354408043.153118: wlan0: STA 00:23:14:bc:b3:e0 WPA: sending 1/2 msg of Group Key Handshakeroot@OpenWrt:~#

Nothing new appears in the log if i try to re-associate with the router.

Here is the config file being used by hostapd:

root@OpenWrt:~# cat /var/run/hostapd-phy0.conf 
ctrl_interface=/var/run/hostapd-phy0
driver=nl80211
wmm_ac_bk_cwmin=4
wmm_ac_bk_cwmax=10
wmm_ac_bk_aifs=7
wmm_ac_bk_txop_limit=0
wmm_ac_bk_acm=0
wmm_ac_be_aifs=3
wmm_ac_be_cwmin=4
wmm_ac_be_cwmax=10
wmm_ac_be_txop_limit=0
wmm_ac_be_acm=0
wmm_ac_vi_aifs=2
wmm_ac_vi_cwmin=3
wmm_ac_vi_cwmax=4
wmm_ac_vi_txop_limit=94
wmm_ac_vi_acm=0
wmm_ac_vo_aifs=2
wmm_ac_vo_cwmin=2
wmm_ac_vo_cwmax=3
wmm_ac_vo_txop_limit=47
wmm_ac_vo_acm=0
tx_queue_data3_aifs=7
tx_queue_data3_cwmin=15
tx_queue_data3_cwmax=1023
tx_queue_data3_burst=0
tx_queue_data2_aifs=3
tx_queue_data2_cwmin=15
tx_queue_data2_cwmax=63
tx_queue_data2_burst=0
tx_queue_data1_aifs=1
tx_queue_data1_cwmin=7
tx_queue_data1_cwmax=15
tx_queue_data1_burst=3.0
tx_queue_data0_aifs=1
tx_queue_data0_cwmin=3
tx_queue_data0_cwmax=7
tx_queue_data0_burst=1.5
hw_mode=g
channel=11




logger_syslog=127
logger_syslog_level=2
logger_stdout=127
logger_stdout_level=2
preamble=0

interface=wlan0
ctrl_interface=/var/run/hostapd-phy0
disassoc_low_ack=1
wpa_passphrase=(removed)
auth_algs=1
wpa=2
wpa_pairwise=CCMP
ssid=HACKEDBOXWIFII
bridge=br-lan
wmm_enabled=1
bssid=00:16:01:11:42:57
ignore_broadcast_ssid=0

additionally, on kill and reboot the output file is created on start of process, but does not contain any data until the second time someone associates with the a/p...

comment:2 Changed 5 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

looks like a (fixed) duplicate of #11894

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.