Modify

Opened 5 years ago

Last modified 4 years ago

#12424 new defect

route6 IPv6 routes are not applied

Reported by: fsckspam@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Running AA (r34004) on a rather old WGT634U as router / firewall (w/o Wifi enabled).
I have an IPv6 address configured on the lan interface as an alias and added two route6 configs like this:

config 'alias'

option 'interface' 'lan'
option 'proto' 'static'
option 'ip6addr' 'xxxx:yyyy:zzzz::1/64'

config 'route6'

option 'interface' 'lan'
option 'target' 'xxxx:yyyy:zzzz:1::/64'
option 'gateway' 'xxxx:yyyy:zzzz::2'

config 'route6'

option 'interface' 'lan'
option 'target' 'xxxx:yyyy:zzzz:2::/64'
option 'gateway' 'xxxx:yyyy:zzzz::3'

The routes are never applied. Manually adding them (via ip -6) works, of course. For now I added a hotplug script that applies the rules manually once lan is up.

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by cheungpat

The script to apply the route6 config was moved aside at r28495.

Try save this file under /etc/hotplug.d/iface and it should work:

source:trunk/package/base-files-network/files/etc/hotplug.d/iface/10-routes@28495

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.