Modify

Opened 5 years ago

Last modified 2 years ago

#12407 reopened defect

Buildbots fail to build Orion target due to kernel size

Reported by: anonymous Owned by: kaloz
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

Buildbots fail to build Orion target in trunk due to kernel size: http://buildbot.openwrt.org/builders/orion/builds/113/steps/compile_8/logs/stdio

ERROR: /build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-uImage.jffs2 too big (> 1048576 bytes)

Maybe the size reserved for kernel should be increased?

Larger context:

Image Name:   Linux-3.3.8
Created:      Fri Nov  2 00:30:05 2012
Image Type:   ARM Linux Kernel Image (uncompressed)
Data Size:    1079792 Bytes = 1054.48 kB = 1.03 MB
Load Address: 00008000
Entry Point:  00008000
  Image arch/arm/boot/uImage is ready
make[4]: Leaving directory `/ramdisk/openwrt/linux-orion_generic/linux-3.3.8'
arm-openwrt-linux-uclibcgnueabi-objcopy -O binary -R .reginfo -R .notes -R .note -R .comment -R .mdebug -R .note.gnu.build-id -S /build/openwrt/slave/orion/build/build_dir/linux-orion_generic/linux-3.3.8/vmlinux /build/openwrt/slave/orion/build/build_dir/linux-orion_generic/vmlinux
arm-openwrt-linux-uclibcgnueabi-objcopy -R .reginfo -R .notes -R .note -R .comment -R .mdebug -R .note.gnu.build-id -S /build/openwrt/slave/orion/build/build_dir/linux-orion_generic/linux-3.3.8/vmlinux /build/openwrt/slave/orion/build/build_dir/linux-orion_generic/vmlinux.elf
touch /build/openwrt/slave/orion/build/build_dir/linux-orion_generic/linux-3.3.8/.image
make -C image compile install TARGET_BUILD=
make[4]: Entering directory `/build/openwrt/slave/orion/build/target/linux/orion/image'
make[4]: `compile' is up to date.
### Dummy comment for indented calls of Image/Prepare
cp '/build/openwrt/slave/orion/build/build_dir/linux-orion_generic/linux-3.3.8/arch/arm/boot/zImage' '/build/openwrt/slave/orion/build/bin/orion/openwrt-orion-generic-zImage'
# Use symbolic permissions to avoid clobbering SUID/SGID/sticky bits
/usr/bin/find /build/openwrt/slave/orion/build/build_dir/target-arm_v5te_uClibc-0.9.33.2_eabi/root-orion -type f -not -perm +0100 -not -name 'ssh_host*' -not -name 'shadow' -print0 | xargs -r -0 chmod u+rw,g+r,o+r
/usr/bin/find /build/openwrt/slave/orion/build/build_dir/target-arm_v5te_uClibc-0.9.33.2_eabi/root-orion -type f -perm +0100 -print0 | xargs -r -0 chmod u+rwx,g+rx,o+rx
/usr/bin/find /build/openwrt/slave/orion/build/build_dir/target-arm_v5te_uClibc-0.9.33.2_eabi/root-orion -type d -print0 | xargs -r -0 chmod u+rwx,g+rx,o+rx
install -d -m0755 /build/openwrt/slave/orion/build/build_dir/target-arm_v5te_uClibc-0.9.33.2_eabi/root-orion/tmp
chmod 1777 /build/openwrt/slave/orion/build/build_dir/target-arm_v5te_uClibc-0.9.33.2_eabi/root-orion/tmp
### Dummy comment for indented calls of Image/BuildKernel
# orion kernel zImage for wn802t
echo -en "\x0c\x1c\xa0\xe3\xea\x10\x81\xe3" > '/build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-zImage'
cat '/build/openwrt/slave/orion/build/build_dir/linux-orion_generic/linux-3.3.8/arch/arm/boot/zImage' >> '/build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-zImage'
cp '/build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-zImage' '/build/openwrt/slave/orion/build/bin/orion/openwrt-wn802t-zImage'
# orion kernel uImage for wn802t
'/build/openwrt/slave/orion/build/staging_dir/host/bin/mkimage' -A arm -O linux -T kernel -C none -a 0x00008000 -e 0x00008000 -n 'Linux-3.3.8' -d '/build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-zImage' '/build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-uImage'
Image Name:   Linux-3.3.8
Created:      Fri Nov  2 00:30:05 2012
Image Type:   ARM Linux Kernel Image (uncompressed)
Data Size:    1079800 Bytes = 1054.49 kB = 1.03 MB
Load Address: 00008000
Entry Point:  00008000
cp '/build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-uImage' '/build/openwrt/slave/orion/build/bin/orion/openwrt-wn802t-uImage'
# orion kernel uImage for wn802t in JFFS2-64k partition
rm -rf '/build/openwrt/slave/orion/build/tmp/wn802t_jffs2_uimage'
mkdir '/build/openwrt/slave/orion/build/tmp/wn802t_jffs2_uimage'
cp '/build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-uImage' '/build/openwrt/slave/orion/build/tmp/wn802t_jffs2_uimage/uImage'
/build/openwrt/slave/orion/build/staging_dir/host/bin/mkfs.jffs2 --compression-mode=none --pad --little-endian --squash -e 64KiB -o '/build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-uImage.jffs2' -d '/build/openwrt/slave/orion/build/tmp/wn802t_jffs2_uimage'
rm -rf '/build/openwrt/slave/orion/build/tmp/wn802t_jffs2_uimage'
[ `stat -c %s '/build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-uImage.jffs2'` -le 1048576 ] || { echo '   ERROR: /build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-uImage.jffs2 too big (> 1048576 bytes)'; exit 1; }
   ERROR: /build/openwrt/slave/orion/build/build_dir/linux-orion_generic/wn802t-uImage.jffs2 too big (> 1048576 bytes)
make[4]: *** [install] Error 1

Attachments (0)

Change History (19)

comment:1 Changed 5 years ago by anonymous

Kernel size is defined here:
https://dev.openwrt.org/browser/trunk/target/linux/orion/image/generic.mk#L17

## Kernel mtd partition size in KiB
KERNEL_MTD_SIZE:=1024

comment:2 Changed 5 years ago by florian

  • Owner changed from developers to kaloz
  • Status changed from new to assigned

comment:3 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from assigned to closed

after a bit of debloating, it should be fixed in r34999

comment:4 Changed 5 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Not yet fixed :-(
Still 21 kB too large as of 35016.

http://buildbot.openwrt.org:8010/builders/orion/builds/143/steps/compile_8/logs/stdio

Image Name:   Linux-3.3.8
Created:      Sat Jan  5 18:20:25 2013
Image Type:   ARM Linux Kernel Image (uncompressed)
Data Size:    1069584 Bytes = 1044.52 kB = 1.02 MB
Load Address: 00008000
Entry Point:  00008000
cp '/build/openwrt/slave/orion/build/build_dir/target-arm_v5te_uClibc-0.9.33.2_eabi/linux-orion_generic/wn802t-uImage' '/build/openwrt/slave/orion/build/bin/orion/openwrt-wn802t-uImage'
# orion kernel uImage for wn802t in JFFS2-64k partition
rm -rf '/build/openwrt/slave/orion/build/tmp/wn802t_jffs2_uimage'
mkdir '/build/openwrt/slave/orion/build/tmp/wn802t_jffs2_uimage'
cp '/build/openwrt/slave/orion/build/build_dir/target-arm_v5te_uClibc-0.9.33.2_eabi/linux-orion_generic/wn802t-uImage' '/build/openwrt/slave/orion/build/tmp/wn802t_jffs2_uimage/uImage'
/build/openwrt/slave/orion/build/staging_dir/host/bin/mkfs.jffs2 --compression-mode=none --pad --little-endian --squash -e 64KiB -o '/build/openwrt/slave/orion/build/build_dir/target-arm_v5te_uClibc-0.9.33.2_eabi/linux-orion_generic/wn802t-uImage.jffs2' -d '/build/openwrt/slave/orion/build/tmp/wn802t_jffs2_uimage'
rm -rf '/build/openwrt/slave/orion/build/tmp/wn802t_jffs2_uimage'
[ `stat -c %s '/build/openwrt/slave/orion/build/build_dir/target-arm_v5te_uClibc-0.9.33.2_eabi/linux-orion_generic/wn802t-uImage.jffs2'` -le 1048576 ] || { echo '   ERROR: /build/openwrt/slave/orion/build/build_dir/target-arm_v5te_uClibc-0.9.33.2_eabi/linux-orion_generic/wn802t-uImage.jffs2 too big (> 1048576 bytes)'; exit 1; }
   ERROR: /build/openwrt/slave/orion/build/build_dir/target-arm_v5te_uClibc-0.9.33.2_eabi/linux-orion_generic/wn802t-uImage.jffs2 too big (> 1048576 bytes)

comment:6 Changed 4 years ago by strikernl

Still happening 9 months later:
http://buildbot.openwrt.org:8010/builders/orion/builds/404/steps/compile_8/logs/stdio

Is "Data size:" the relevant size? because it's 1047744 here, less than 1048576
Am I missing something here?

Last edited 4 years ago by strikernl (previous) (diff)

comment:7 Changed 3 years ago by anonymous

Is no one working on this anymore?

comment:8 Changed 3 years ago by johnc

Chaos Calmer RC1 does not include Orion , neither did Barrier Breaker. There is now no option to compile via the make menu either. Kaloz , has support for this architecture been officially dropped?

comment:9 follow-up: Changed 3 years ago by anonymous

Orion and some other were marked as broken by r44968.
You need to enable "Show broken platforms/packages" under "Advanced configuration options (for developers)" to be able to select it.
However, current trunk is only compile tested ( r45405) and I can confirm that it doesn't work (at least not on wrt350nv2; It looks like its not even booting - after power on, the power led stays on while on older revisions it went off for a couple of seconds and then back on again. Can't say why, because I don't have serial or jtag, sorry).
I was able to build r45374 with kernel 3.14 (.43, with minor modifications, just before 3.14 was dropped; luci, relayd, ath debug). It works allright, on wrt350n no problems so far, others I can't say. You can get the images here.

comment:10 in reply to: ↑ 9 Changed 3 years ago by anonymous

Replying to anonymous:

Orion and some other were marked as broken by r44968.
You need to enable "Show broken platforms/packages" under "Advanced configuration options (for developers)" to be able to select it.
However, current trunk is only compile tested ( r45405) and I can confirm that it doesn't work (at least not on wrt350nv2; It looks like its not even booting - after power on, the power led stays on while on older revisions it went off for a couple of seconds and then back on again. Can't say why, because I don't have serial or jtag, sorry).
I was able to build r45374 with kernel 3.14 (.43, with minor modifications, just before 3.14 was dropped; luci, relayd, ath debug). It works allright, on wrt350n no problems so far, others I can't say. You can get the images here.

Forgot to mention that stripping "unnecessary exports from the kernel image" makes away with this error.

comment:11 Changed 3 years ago by johnc

Thank you anon. Appreciate the info and the compiled build.

comment:12 Changed 2 years ago by strikernl

I can verify that the build linked by anonymous (r45374) works, I'm running it now.

 -----------------------------------------------------
 CHAOS CALMER (Bleeding Edge, r45374)
 -----------------------------------------------------

I tried building the latest bleeding edge and it didn't boot either. I'll try to get back soon with output from serial, and see why it's not booting.

comment:13 Changed 2 years ago by strikernl

OK, I tried running it with serial attached (r46945):

 DESIGNATED DRIVER (Bleeding Edge, r46945)

Unfortunately it seems to lock up fairly early in the process: http://pastebin.com/raw.php?i=7y2uvTZH

Basically it gets stuck pretty soon, right after

Starting kernel ...

Uncompressing Linux... done, booting the kernel.

After that nothing seems to happen at all, I've waited for around 10 minutes.

Is there anything I can do in order to get more (debug) information?

Last edited 2 years ago by strikernl (previous) (diff)

comment:15 Changed 2 years ago by anonymous

This patch seems to do the job:
http://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/patch/?id=330349fae46f8400e86ef98ee05af4ba13466f49
Created a quick 800-orion_irq_fixes.patch in /target/linux/orion/patches and it looks like it is working with r47364; tested only WRT350N v2. So far no problems with it, kernel log and system log report no errors.

comment:16 Changed 2 years ago by strikernl

@anonymous thank you, do you have an image that I could test to confirm?

comment:18 Changed 2 years ago by strikernl

Apologies, it took me a while, but I can confirm that this fix and the above build works fine. Thanks @anonymous!

See also the boot logs.
http://pastebin.com/raw.php?i=qSyH4ivL

Is there anyway we can get orion added back to buildbots?

comment:19 Changed 2 years ago by strikernl

Ping?

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.