Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12363 closed defect (fixed)

UCI or netifd doesn't return defaultroute=1 when it was not set

Reported by: Yar Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Attitude Adjustment 12.09 Beta
Keywords: Cc:

Description

Hello, here is my problem. I try to investigate why there is nodefaultroute in xl2tpd-generated ppp config. I found that /lib/netifd/proto/l2tp.sh see "" instead of "1" in case when defaultroute was deleted for this interface. Luci set default route to '0' when "Use default gateway" is off and delete this setting if "Use default gateway" is on.

Problem is not very big - route still created by ppp-up, but when interface is down, default route was not restored (unlike replacedefaultroute option do)

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by anonymous

P.S. when I set it by hand, with uci set network.myprovider.defaultroute=1, then all works as intended.

comment:2 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in newer versions. nodefaultroute is still there, but netifd sets the route not pppd

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.