Modify

Opened 5 years ago

Closed 3 years ago

#12322 closed defect (wontfix)

openl2tp with pppd 2.4.5 doesnt work

Reported by: anonymous Owned by: jow
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Attitude Adjustment 12.09 Beta
Keywords: Cc:

Description

When tunnel an session established, pppd not start with error:

pppd: symbol 'multilink_master': can't resolve symbol in lib '/usr/lib/pppd/2.4.5/openl2tp.so'.
pppd: Couldn't load plugin openl2tp.so

It seems like pppd compiled without multilink support and openl2tp plugin requires this feature.

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

comment:2 Changed 5 years ago by dgolle@…

Is there any reason why you use openl2tp instead of xl2tpd?
As xl2tpd now also supports kernel-mode L2TP, I believe we should drop openl2tp and add whatever missing to xl2tpd.

comment:3 Changed 5 years ago by anonymous

Thanks. I will try xl2tpd.
Also i found package ppp-multilink_2.4.5-6_x86.ipk in repository, openl2tp works with this package.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:5 Changed 3 years ago by jogo

  • Resolution set to wontfix
  • Status changed from accepted to closed

Openl2tp is unmaintained. No changes will be made to it until it is submitted to github and maintained by somebody.
See https://github.com/openwrt/packages/blob/master/CONTRIBUTING.md for details.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.