Modify

Opened 5 years ago

Closed 5 years ago

#12295 closed defect (fixed)

wndr3700v2: kmod-ledtrig-netdev breaks image compilation

Reported by: anonymous Owned by: nbd
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

Arch: AR7xxx
Machine: WNDR3700v2
Revision: trunk r33675

Hi,
'kmod-ledtrig-netdev' package seems to break image compilation, even after 'make clean'.
If package is either not selected or selected as module, everything is OK.
Notice that quite recently as r33613 everything was also OK.

...
Configuring kmod-nls-iso8859-15.
Configuring kmod-nls-iso8859-1.
Configuring luci-app-p910nd.
Configuring nut-logger.
Configuring bc.
Configuring luci.
Configuring fdisk.
Configuring usbreset.
Configuring libdb47.
Configuring netatalk.
Configuring dumpe2fs.
Configuring picocom.
Configuring nut-driver-blazer_usb.
Configuring wireless-tools.
Configuring luci-app-hd-idle.
Configuring kmod-ledtrig-netdev.
Collected errors:
 * opkg_install_cmd: Cannot install package .
make[2]: *** [package/install] Error 255
make[2]: Leaving directory `/home/openwrt/trunk'
make[1]: *** [/home/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_install] Error 2
make[1]: Leaving directory `/home/openwrt/trunk'
make: *** [world] Error 2

Attachments (2)

config_wndr3700v2 (19.3 KB) - added by anonymous 5 years ago.
pkginfo.tar.gz (14.8 KB) - added by anonymous 5 years ago.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by anonymous

comment:1 follow-up: Changed 5 years ago by nbd

  • Owner changed from developers to nbd
  • Status changed from new to accepted

for some reason i can't reproduce your issue with your config, please attach a tarball with the contents of staging_dir/target-*/pkginfo

comment:2 in reply to: ↑ 1 Changed 5 years ago by anonymous

Replying to nbd:

for some reason i can't reproduce your issue with your config, please attach a tarball with the contents of staging_dir/target-*/pkginfo

Hi nbd,
Here are the files you requested. I looked into them but didn't find anything suspicious.
BTW, I even did 'make dirclean' but the problem persists.
Could it be something introduced by r33631 and/or r33633.

Thanks for your quick reply.

Changed 5 years ago by anonymous

comment:3 Changed 5 years ago by anonymous

Hello,
Here's some info when 'kmod-ledtrig-netdev' package is selected as <M>.
Notice that the problem seems to hapen after 'Configuring luci-app-hd-idle' message.

...
Configuring kmod-nls-iso8859-15.
Configuring kmod-nls-iso8859-1.
Configuring luci-app-p910nd.
Configuring bc.
Configuring luci.
Configuring fdisk.
Configuring usbreset.
Configuring libdb47.
Configuring netatalk.
Configuring dumpe2fs.
Configuring picocom.
Configuring wireless-tools.
Configuring luci-app-hd-idle.
Setting flags for package kernel to hold.
Setting flags for package kmod-scsi-core to hold.
Setting flags for package kmod-crypto-core to hold.
Setting flags for package kmod-crypto-aes to hold.
Setting flags for package kmod-crypto-arc4 to hold.
Setting flags for package kmod-fs-ext4 to hold.
Setting flags for package kmod-fuse to hold.
Setting flags for package kmod-fs-ntfs to hold.
Setting flags for package kmod-fs-vfat to hold.
Setting flags for package kmod-leds-gpio to hold.
Setting flags for package kmod-ledtrig-usbdev to hold.
Setting flags for package kmod-ledtrig-default-on to hold.
Setting flags for package kmod-ledtrig-timer to hold.
Setting flags for package kmod-lib-crc-ccitt to hold.
Setting flags for package kmod-lib-crc16 to hold.
...

Today I also tried to build after applying the patch attached to ticket #12317, but with no success. Image geneation breaks at the same point.

...
Configuring kmod-nls-iso8859-15.
Configuring kmod-nls-iso8859-1.
Configuring luci-app-p910nd.
Configuring nut-logger.
Configuring bc.
Configuring luci.
Configuring fdisk.
Configuring usbreset.
Configuring libdb47.
Configuring netatalk.
Configuring dumpe2fs.
Configuring picocom.
Configuring nut-driver-blazer_usb.
Configuring wireless-tools.
Configuring luci-app-hd-idle.
Configuring kmod-ledtrig-netdev.
Collected errors:
 * opkg_install_cmd: Cannot install package 2.6.5.     <====
make[2]: *** [package/install] Error 255
make[2]: Leaving directory `/home/openwrt/trunk'
make[1]: *** [/home/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_install] Error 2
make[1]: Leaving directory `/home/openwrt/trunk'
make: *** [world] Error 2

Notice that the marked line changes slightly.

After rolling back r33631 and r33633 everything works fine.

comment:4 Changed 5 years ago by anonymous

Hi,
I think that r34106 somehow solved the problem.
Compilation successful after 'make clean' and tmp/ dir cleanup.

comment:5 Changed 5 years ago by anonymous

Compilation after 'make dirclean' is fine also. I think the ticket can be closed.

comment:6 Changed 5 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.