Modify

Opened 5 years ago

Closed 2 years ago

Last modified 2 years ago

#12275 closed defect (invalid)

Unable to: opkg update, due to HTTP/1.1 404 Not Found

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hello,

the command
opkg download
fails because http://downloads.openwrt.org/snapshots is empty
so http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages cannot be accessed,
which results in:

Downloading http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found

Attachments (0)

Change History (18)

comment:1 Changed 5 years ago by anonymous

Should be fixed now

comment:2 Changed 5 years ago by spyros8_6@…

I must say that no it is not fixed (as of GMT 21:52)

comment:3 Changed 5 years ago by anonymous

still empty

comment:4 Changed 5 years ago by anonymous

when will the files come back?

comment:5 Changed 5 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

Might be a week or more. Also dupe of #12257

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:8 Changed 3 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

it is empty today

comment:10 Changed 3 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

broken at the minute both base and packages returning 404, if you turned gzip deflate on then the perfectly usable Packages file would work if you tried to access Packages.gz

comment:11 Changed 3 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

Has been fixed with r45771. As a workaround switch src/gz to src in opkg.conf. The next snapshot iteration will readd the missing Packages.gz files.

comment:12 Changed 2 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Currently none of the download servers are working,
how to fix the opkg udate.

comment:13 Changed 2 years ago by anonymous

use CC or compile yourself...

comment:14 Changed 2 years ago by anonymous

Yes, use 15.05 stable or compile your own versions.

This bug can be closed once again. This is not a support forum.

comment:15 Changed 2 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:16 follow-up: Changed 2 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

How are you suppose to install packages or update trunk version of OpenWRT without opkg update????

comment:17 Changed 2 years ago by nbd

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:18 in reply to: ↑ 16 Changed 2 years ago by anonymous

Replying to anonymous:

How are you suppose to install packages or update trunk version of OpenWRT without opkg update????

By following our instructions. If you don't understand how trunk builds works, then you should be on a stable release.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.