Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12269 closed defect (fixed)

RB433UAH and Top (3rd) minipci slot not working

Reported by: doghead@… Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

We are trying to run OpenWRT on an Mikrotik RB433UAH with two RB52H (AR5414) modules on it. The enclosure we are using requires that we use the top two miniPCI slots. Can't change the enclosure and we can't fit a module in the bottom slot.

We are using the ath5K driver with mac80211 under kernel 3.2.5.

One radio is being used as an AP on 2.4GHz and the other is using AdHoc mesh using batman-adv. When we put the radios in the bottom two miniPCI slots all is well and the mesh works and the AP works. But...

When we move the radio from the bottom slot to the top slot, we lose radio signal from it. It is recognized as being present, the driver loads, everything looks like it should be working, but there is no RF signal. If we swap the functions of the radios around, whichever is using the top slot fails to work. The center and bottom slot work fine. We have tried this on several RB433 and they all behave the same.

We need to use kernel 3.2.5 because of some other drivers we are using and we cannot use ROS as they do not support the LTE modem we have to use.

Is there a problem with power to the top slot or something like that which would prevent the radio from working? PCI card sense? any ideas?

PCI sees it:
lspci
00:12.0 Ethernet controller: Atheros Communications Inc. AR5413/AR5414 Wireless Network Adapter [AR5006X(S) 802.11abg] (rev 01)
00:14.0 Ethernet controller: Atheros Communications Inc. AR5413/AR5414 Wireless Network Adapter [AR5006X(S) 802.11abg] (rev 01)

Logs don't show any problem:
dmesg | grep ath5k
[ 24.580000] ath5k 0000:00:12.0: registered as 'phy0'
[ 25.250000] ath5k phy0: Atheros AR5414 chip found (MAC: 0xa5, PHY: 0x61)
[ 25.260000] ath5k 0000:00:14.0: registered as 'phy1'
[ 26.000000] ath5k phy1: Atheros AR5414 chip found (MAC: 0xa5, PHY: 0x61)

iwconfig looks good
iwconfig
wlan1 IEEE 802.11abg ESSID:"GERMesh"
Mode:Ad-Hoc Frequency:5.825 GHz Cell: 16:51:08:FA:77:53
Tx-Power=24 dBm
RTS thr=2346 B Fragment thr=2346 B
Encryption key:off
Power Management:on
wlan0 IEEE 802.11abg Mode:Master Frequency:2.412 GHz Tx-Power=24 dBm
RTS thr=2346 B Fragment thr=2346 B
Power Management:off
mon.wlan0 IEEE 802.11abg Mode:Monitor Frequency:2.412 GHz Tx-Power=24 dBm
RTS thr=2346 B Fragment thr=2346 B
Power Management:on

The kernel modules are all there. I tried disabling ath9k by both building without it and black listing it, but that made no difference.
lsmod | grep ath
ath9k 88800 0
ath9k_common 1152 1 ath9k
ath9k_hw 347408 2 ath9k,ath9k_common
ath5k 146704 0
ath 14112 4 ath9k,ath9k_common,ath9k_hw,ath5k
mac80211 233312 2 ath9k,ath5k
cfg80211 134336 4 ath9k,ath5k,ath,mac80211

iw info shows the cards
iw phy0 info
Wiphy phy0
Band 1:
Frequencies:

  • 2412 MHz [1] (30.0 dBm)
  • 2417 MHz [2] (30.0 dBm)
  • 2422 MHz [3] (30.0 dBm)
  • 2427 MHz [4] (30.0 dBm)
  • 2432 MHz [5] (30.0 dBm)
  • 2437 MHz [6] (30.0 dBm)
  • 2442 MHz [7] (30.0 dBm)
  • 2447 MHz [8] (30.0 dBm)
  • 2452 MHz [9] (30.0 dBm)
  • 2457 MHz [10] (30.0 dBm)
  • 2462 MHz [11] (30.0 dBm)
  • 2467 MHz [12] (disabled)
  • 2472 MHz [13] (disabled)
  • 2484 MHz [14] (disabled)

Bitrates (non-HT):

  • 1.0 Mbps
  • 2.0 Mbps (short preamble supported)
  • 5.5 Mbps (short preamble supported)
  • 11.0 Mbps (short preamble supported)
  • 6.0 Mbps
  • 9.0 Mbps
  • 12.0 Mbps
  • 18.0 Mbps
  • 24.0 Mbps
  • 36.0 Mbps
  • 48.0 Mbps
  • 54.0 Mbps

Band 2:
Frequencies:

  • 5040 MHz [8] (disabled)
  • 5060 MHz [12] (disabled)
  • 5080 MHz [16] (disabled)
  • 5180 MHz [36] (30.0 dBm)
  • 5200 MHz [40] (30.0 dBm)
  • 5220 MHz [44] (30.0 dBm)
  • 5240 MHz [48] (30.0 dBm)
  • 5260 MHz [52] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5280 MHz [56] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5300 MHz [60] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5320 MHz [64] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5500 MHz [100] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5520 MHz [104] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5540 MHz [108] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5560 MHz [112] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5580 MHz [116] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5600 MHz [120] (disabled)
  • 5620 MHz [124] (disabled)
  • 5640 MHz [128] (disabled)
  • 5660 MHz [132] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5680 MHz [136] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5700 MHz [140] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5745 MHz [149] (30.0 dBm)
  • 5765 MHz [153] (30.0 dBm)
  • 5785 MHz [157] (30.0 dBm)
  • 5805 MHz [161] (30.0 dBm)
  • 5825 MHz [165] (30.0 dBm)

Bitrates (non-HT):

  • 6.0 Mbps
  • 9.0 Mbps
  • 12.0 Mbps
  • 18.0 Mbps
  • 24.0 Mbps
  • 36.0 Mbps
  • 48.0 Mbps
  • 54.0 Mbps

max # scan SSIDs: 4
max scan IEs length: 2285 bytes
Fragmentation threshold: 2346
RTS threshold: 2346
Coverage class: 3 (up to 1350m)
Supported Ciphers:

  • WEP40 (00-0f-ac:1)
  • WEP104 (00-0f-ac:5)
  • TKIP (00-0f-ac:2)
  • CCMP (00-0f-ac:4)

Available Antennas: TX 0x3 RX 0x3
Configured Antennas: TX 0x3 RX 0x3
Supported interface modes:

  • IBSS
  • managed
  • AP
  • AP/VLAN
  • monitor
  • mesh point

software interface modes (can always be added):

  • AP/VLAN
  • monitor

interface combinations are not supported
Supported commands:

  • new_interface
  • set_interface
  • new_key
  • new_beacon
  • new_station
  • new_mpath
  • set_mesh_params
  • set_bss
  • authenticate
  • associate
  • deauthenticate
  • disassociate
  • join_ibss
  • join_mesh
  • remain_on_channel
  • set_tx_bitrate_mask
  • action
  • frame_wait_cancel
  • set_wiphy_netns
  • set_channel
  • set_wds_peer
  • Unknown command (84)
  • Unknown command (87)
  • Unknown command (85)
  • connect
  • disconnect

Supported TX frame types:

  • IBSS: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • managed: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • AP: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • AP/VLAN: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • mesh point: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • P2P-client: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • P2P-GO: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0

Supported RX frame types:

  • IBSS: 0x00d0
  • managed: 0x0040 0x00d0
  • AP: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
  • AP/VLAN: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
  • mesh point: 0x00b0 0x00c0 0x00d0
  • P2P-client: 0x0040 0x00d0
  • P2P-GO: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0

Device supports RSN-IBSS.
HT Capability overrides:

  • MCS: ff ff ff ff ff ff ff ff ff ff
  • maximum A-MSDU length
  • supported channel width
  • short GI for 40 MHz
  • max A-MPDU length exponent
  • min MPDU start spacing

Device supports HT-IBSS.
iw phy1 info
Wiphy phy1
Band 1:
Frequencies:

  • 2412 MHz [1] (30.0 dBm)
  • 2417 MHz [2] (30.0 dBm)
  • 2422 MHz [3] (30.0 dBm)
  • 2427 MHz [4] (30.0 dBm)
  • 2432 MHz [5] (30.0 dBm)
  • 2437 MHz [6] (30.0 dBm)
  • 2442 MHz [7] (30.0 dBm)
  • 2447 MHz [8] (30.0 dBm)
  • 2452 MHz [9] (30.0 dBm)
  • 2457 MHz [10] (30.0 dBm)
  • 2462 MHz [11] (30.0 dBm)
  • 2467 MHz [12] (disabled)
  • 2472 MHz [13] (disabled)
  • 2484 MHz [14] (disabled)

Bitrates (non-HT):

  • 1.0 Mbps
  • 2.0 Mbps (short preamble supported)
  • 5.5 Mbps (short preamble supported)
  • 11.0 Mbps (short preamble supported)
  • 6.0 Mbps
  • 9.0 Mbps
  • 12.0 Mbps
  • 18.0 Mbps
  • 24.0 Mbps
  • 36.0 Mbps
  • 48.0 Mbps
  • 54.0 Mbps

Band 2:
Frequencies:

  • 5040 MHz [8] (disabled)
  • 5060 MHz [12] (disabled)
  • 5080 MHz [16] (disabled)
  • 5180 MHz [36] (30.0 dBm)
  • 5200 MHz [40] (30.0 dBm)
  • 5220 MHz [44] (30.0 dBm)
  • 5240 MHz [48] (30.0 dBm)
  • 5260 MHz [52] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5280 MHz [56] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5300 MHz [60] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5320 MHz [64] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5500 MHz [100] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5520 MHz [104] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5540 MHz [108] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5560 MHz [112] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5580 MHz [116] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5600 MHz [120] (disabled)
  • 5620 MHz [124] (disabled)
  • 5640 MHz [128] (disabled)
  • 5660 MHz [132] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5680 MHz [136] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5700 MHz [140] (30.0 dBm) (passive scanning, no IBSS, radar detection)
  • 5745 MHz [149] (30.0 dBm)
  • 5765 MHz [153] (30.0 dBm)
  • 5785 MHz [157] (30.0 dBm)
  • 5805 MHz [161] (30.0 dBm)
  • 5825 MHz [165] (30.0 dBm)

Bitrates (non-HT):

  • 6.0 Mbps
  • 9.0 Mbps
  • 12.0 Mbps
  • 18.0 Mbps
  • 24.0 Mbps
  • 36.0 Mbps
  • 48.0 Mbps
  • 54.0 Mbps

max # scan SSIDs: 4
max scan IEs length: 2285 bytes
Fragmentation threshold: 2346
RTS threshold: 2346
Coverage class: 3 (up to 1350m)
Supported Ciphers:

  • WEP40 (00-0f-ac:1)
  • WEP104 (00-0f-ac:5)
  • TKIP (00-0f-ac:2)
  • CCMP (00-0f-ac:4)

Available Antennas: TX 0x3 RX 0x3
Configured Antennas: TX 0x3 RX 0x3
Supported interface modes:

  • IBSS
  • managed
  • AP
  • AP/VLAN
  • monitor
  • mesh point

software interface modes (can always be added):

  • AP/VLAN
  • monitor

interface combinations are not supported
Supported commands:

  • new_interface
  • set_interface
  • new_key
  • new_beacon
  • new_station
  • new_mpath
  • set_mesh_params
  • set_bss
  • authenticate
  • associate
  • deauthenticate
  • disassociate
  • join_ibss
  • join_mesh
  • remain_on_channel
  • set_tx_bitrate_mask
  • action
  • frame_wait_cancel
  • set_wiphy_netns
  • set_channel
  • set_wds_peer
  • Unknown command (84)
  • Unknown command (87)
  • Unknown command (85)
  • connect
  • disconnect

Supported TX frame types:

  • IBSS: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • managed: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • AP: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • AP/VLAN: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • mesh point: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • P2P-client: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
  • P2P-GO: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0

Supported RX frame types:

  • IBSS: 0x00d0
  • managed: 0x0040 0x00d0
  • AP: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
  • AP/VLAN: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
  • mesh point: 0x00b0 0x00c0 0x00d0
  • P2P-client: 0x0040 0x00d0
  • P2P-GO: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0

Device supports RSN-IBSS.
HT Capability overrides:

  • MCS: ff ff ff ff ff ff ff ff ff ff
  • maximum A-MSDU length
  • supported channel width
  • short GI for 40 MHz
  • max A-MPDU length exponent
  • min MPDU start spacing

Device supports HT-IBSS.
2 duvi Yesterday 08:46:30

Member
Offline

Registered: 2008-05-11
Posts: 30

I've been experiencing the exact same thing in my RB433UAH.

It started after OpenWRT trunk switched to kernel 3.x

If I have one of the cards in the top slot, it's not working.
Everything seems normal, cards detected as shonw in dmesg, iwconfig prints correct numbers, but still, no real world signal can be seen.

We should open a ticket about this, once openwrt trac page is back online again (:

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by doghead@…

This is not a hardware issue, it is a driver issue, perhaps with PCI for the AR71xx. Under Mikrotik OS there is no issue. With ath9k the issue is still there. Move cards from bottom working slot to top slot with exact same configuration and it fails. 100% replicatable.

We need to use kernel 3 (prefer to use 3.4 but will settle with 3.2.5 or 3.3.8 for now) because we need a driver that is only available for 3, so down rev of kernel is not possible.

We can pay someone to fix this...

comment:2 Changed 5 years ago by duvi

I've been experiencing the exact same thing in my RB433UAH.

It started after OpenWRT trunk switched to kernel 3.x

If I have one of the cards in the top slot, it's not working.
Everything seems normal, cards detected as shown in dmesg, iwconfig prints correct numbers, but still, no real world signal can be seen.

comment:3 Changed 5 years ago by anonymous

Tested with the RB433GL, the RB493 and RB435. All have the same issue in the top slot.

We think that there must be some type of PCI bus enumeration issue. Definitely not a power issue.

comment:4 Changed 5 years ago by juhosg

  • Priority changed from high to response-needed

Should be fixed in r34238, please try it.

comment:5 Changed 5 years ago by duvi

Thanks, now all 3 slots work for me on RB433UAH.

Top slot is: pci0000:00/0000:00:14.0
Middle slot: pci0000:00/0000:00:12.0
Bottom slot: pci0000:00/0000:00:13.0

comment:6 Changed 5 years ago by juhosg

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for testing!

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.