Modify

Opened 5 years ago

Closed 3 years ago

#12268 closed defect (fixed)

php5-mod-iconv compilation error with php-5.4.5 on trunk rev 33544

Reported by: victor.quicksilver@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hello guys, seems like I catched some error on php5-mod-iconv compilation, using eglibc, and libiconv-full, I attach my whole config as a file. Seem's like the same error in the following forum post, but no solutions there https://forum.openwrt.org/viewtopic.php?id=39204 , so I'm opening this ticket.

The error on my machine is the following, I hope it can be easily solved:

echo "extension=iconv.so" > /mnt/openwrt/wrt160nl-new/trunk/build_dir/target-mips_r2_eglibc-2.15/php-5.4.5/ipkg-ar71xx/php5-mod-iconv/etc/php5/iconv.ini
find /mnt/openwrt/wrt160nl-new/trunk/build_dir/target-mips_r2_eglibc-2.15/php-5.4.5/ipkg-ar71xx/php5-mod-iconv -name 'CVS' -o -name '.svn' -o -name '.#*' -o -name '*~'| xargs -r rm -rf
Package php5-mod-iconv is missing dependencies for the following libraries:
libiconv.so.2
make[3]: *** [/mnt/openwrt/wrt160nl-new/trunk/bin/ar71xx/packages/php5-mod-iconv_5.4.5-3_ar71xx.ipk] Error 1
make[3]: Leaving directory `/mnt/openwrt/wrt160nl-new/trunk/feeds/packages/lang/php5'
make[2]: *** [package/feeds/packages/php5/compile] Error 2
make[2]: Leaving directory `/mnt/openwrt/wrt160nl-new/trunk'
make[1]: *** [/mnt/openwrt/wrt160nl-new/trunk/staging_dir/target-mips_r2_eglibc-2.15/stamp/.package_compile] Error 2
make[1]: Leaving directory `/mnt/openwrt/wrt160nl-new/trunk'
make: *** [world] Error 2

Just ask me if you need more info.

Thanks for your support.

Attachments (1)

config (140.3 KB) - added by victor.quicksilver@… 5 years ago.
Configuration that triggers the error.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by victor.quicksilver@…

Configuration that triggers the error.

comment:1 Changed 5 years ago by victor.quicksilver@…

The package can be created if I modify the following lines in the php5, Makefile:

===================================================================
--- Makefile    (revision 33546)
+++ Makefile    (working copy)
@@ -248,7 +248,7 @@
 endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_php5-mod-iconv),)
-  CONFIGURE_ARGS+= --with-iconv=shared,"$(ICONV_PREFIX)"
+  CONFIGURE_ARGS+= --with-iconv=shared,"$(STAGING_DIR)/usr/lib/libiconv-full"
 else
   CONFIGURE_ARGS+= --without-iconv
 endif
@@ -544,7 +544,7 @@
 $(eval $(call BuildModule,gmp,GMP,+PACKAGE_php5-mod-gmp:libgmp))
 $(eval $(call BuildModule,hash,Hash))
 $(eval $(call BuildModule,http,HTTP,+PACKAGE_php5-mod-http:libcurl +PACKAGE_php5-mod-http:libevent2 +PACKAGE_php5-mod-http:librt))
-$(eval $(call BuildModule,iconv,iConv,+PACKAGE_php5-mod-iconv:libiconv))
+$(eval $(call BuildModule,iconv,iConv,+PACKAGE_php5-mod-iconv:libiconv-full))
 $(eval $(call BuildModule,json,JSON))
 $(eval $(call BuildModule,ldap,LDAP,+PACKAGE_php5-mod-ldap:libopenldap +PACKAGE_php5-mod-ldap:libsasl2))
 $(eval $(call BuildModule,libevent,libevent,+PACKAGE_php5-mod-libevent:libevent2))

This can be used as a workaround, cause according to http://www.mail-archive.com/discussion@lists.en.qi-hardware.com/msg01044.html, I shouldn't do this.
Anyway libintl has the same problem in the Makefile, AFAIK.

comment:2 Changed 4 years ago by anonymous

I recently encountered this issue after enabling "Full language support". This posting saved me a lot of time.
Thanks a lot for describing that workaround!!

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:4 Changed 3 years ago by mhei

  • Resolution set to fixed
  • Status changed from new to closed

This problem was fixed in trunk recently. Please upgrade to Chaos Calmer when released.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.