Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12267 closed defect (worksforme)

internal compiler error: in do_assemble_alias, at varasm.c:5444

Reported by: xbahas@… Owned by: developers
Priority: highest Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: internal compiler error Cc:

Description

i cant compile, what is the problem??

bob2@bob-Calistoga-ICH7M-Chipset:~/Desktop/openwrt/trunk$ make V=99
Checking 'xgettext'... ok.
make[1]: Entering directory `/home/bob2/Desktop/openwrt/trunk'
make[2]: Entering directory `/home/bob2/Desktop/openwrt/trunk'
+ mkdir -p /home/bob2/Desktop/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2
+ cd /home/bob2/Desktop/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2
+ mkdir -p bin lib include stamp
mkdir -p /home/bob2/Desktop/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/stamp
touch /home/bob2/Desktop/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/.prepared
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gdb'
make[3]: Nothing to be done for `prepare'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gdb'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gdb'
make[3]: Nothing to be done for `compile'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gdb'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gdb'
make[3]: Nothing to be done for `install'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gdb'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/binutils'
make[3]: Nothing to be done for `prepare'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/binutils'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/binutils'
make[3]: Nothing to be done for `compile'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/binutils'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/binutils'
make[3]: Nothing to be done for `install'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/binutils'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/minimal'
make[3]: Nothing to be done for `prepare'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/minimal'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/minimal'
make[3]: Nothing to be done for `compile'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/minimal'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/minimal'
make[3]: Nothing to be done for `install'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/minimal'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/kernel-headers'
make[3]: Nothing to be done for `prepare'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/kernel-headers'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/kernel-headers'
make[3]: Nothing to be done for `compile'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/kernel-headers'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/kernel-headers'
make[3]: Nothing to be done for `install'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/kernel-headers'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/uClibc/headers'
make[3]: Nothing to be done for `prepare'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/uClibc/headers'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/uClibc/headers'
make[3]: Nothing to be done for `compile'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/uClibc/headers'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/uClibc/headers'
make[3]: Nothing to be done for `install'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/uClibc/headers'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/initial'
make[3]: Nothing to be done for `prepare'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/initial'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/initial'
make[3]: Nothing to be done for `compile'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/initial'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/initial'
make[3]: Nothing to be done for `install'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/gcc/initial'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/uClibc'
make[3]: Nothing to be done for `prepare'.
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/uClibc'
make[3]: Entering directory `/home/bob2/Desktop/openwrt/trunk/toolchain/uClibc'
/home/bob2/Desktop/openwrt/trunk/staging_dir/host/bin/sed -i -e 's,CROSS=.*,CROSS=mips-openwrt-linux-uclibc-,g' /home/bob2/Desktop/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/uClibc-0.9.33.2/Rules.mak
PATH='/home/bob2/Desktop/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/initial/bin:/home/bob2/Desktop/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/bin:/home/bob2/Desktop/openwrt/trunk/staging_dir/host/bin:/home/bob2/Desktop/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/bin:/home/bob2/Desktop/openwrt/trunk/staging_dir/host/bin:/home/bob2/Desktop/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/bin:/home/bob2/Desktop/openwrt/trunk/staging_dir/host/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games' make -C /home/bob2/Desktop/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/uClibc-0.9.33.2 AR=mips-openwrt-linux-uclibc-ar AS="mips-openwrt-linux-uclibc-gcc -c -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float" LD=mips-openwrt-linux-uclibc-ld NM=mips-openwrt-linux-uclibc-nm CC="mips-openwrt-linux-uclibc-gcc" GCC="mips-openwrt-linux-uclibc-gcc" CXX="mips-openwrt-linux-uclibc-g++" RANLIB=mips-openwrt-linux-uclibc-ranlib STRIP=mips-openwrt-linux-uclibc-strip OBJCOPY=mips-openwrt-linux-uclibc-objcopy OBJDUMP=mips-openwrt-linux-uclibc-objdump SIZE=mips-openwrt-linux-uclibc-size DEVEL_PREFIX=/ RUNTIME_PREFIX=/ HOSTCC="gcc" CPU_CFLAGS="-funsigned-char -fno-builtin -fno-asm --std=gnu99 -ffunction-sections -fdata-sections -Wno-unused-but-set-variable -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float" ARCH=""mips"" LIBGCC="/home/bob2/Desktop/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/lib/gcc/mips-openwrt-linux-uclibc/4.6.3/libgcc_initial.a" DOSTRIP="" PREFIX= all
make[4]: Entering directory `/home/bob2/Desktop/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/uClibc-0.9.33.2'
cd ./; make lib/ld-uClibc.so
make[5]: `lib/ld-uClibc.so' is up to date.
mips-openwrt-linux-uclibc-gcc -c libc/misc/internals/errno.c -o libc/misc/internals/errno.os -include ./include/libc-symbols.h -Wall -Wstrict-prototypes -Wstrict-aliasing -funsigned-char -fno-builtin -fno-asm --std=gnu99 -ffunction-sections -fdata-sections -Wno-unused-but-set-variable -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -fno-stack-protector -nostdinc -I./include -I./include -I. -I./libc/sysdeps/linux -I./libc/sysdeps/linux/mips -Os -funit-at-a-time -fmerge-all-constants -fstrict-aliasing -fno-tree-loop-optimize -fno-tree-dominator-opts -fno-strength-reduce -mno-split-addresses -I./libpthread/nptl -I./libpthread/nptl -I./libpthread/nptl/sysdeps/unix/sysv/linux/mips/ -I./libpthread/nptl/sysdeps/unix/sysv/linux/mips -I./libpthread/nptl/sysdeps/mips -I./libpthread/nptl/sysdeps/mips -I./libpthread/nptl/sysdeps/unix/sysv/linux -I./libpthread/nptl/sysdeps/unix/sysv/linux -I./libpthread/nptl/sysdeps/pthread -I./libpthread/nptl/sysdeps/pthread/bits -I./libpthread/nptl/sysdeps/generic -I./ldso/ldso/mips -I./ldso/include -I./libc/sysdeps/linux/common -I/home/bob2/Desktop/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/linux-dev/include/ -isystem /home/bob2/Desktop/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/lib/gcc/mips-openwrt-linux-uclibc/4.6.3/include-fixed -isystem /home/bob2/Desktop/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/lib/gcc/mips-openwrt-linux-uclibc/4.6.3/include -DNDEBUG -DUSE_STDIO_FUTEXES -fPIC -MT libc/misc/internals/errno.os -MD -MP -MF libc/misc/internals/.errno.os.dep
libc/misc/internals/errno.c:8:1: internal compiler error: in do_assemble_alias, at varasm.c:5444
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://dev.openwrt.org/> for instructions.
make[4]: * [libc/misc/internals/errno.os] Error 1
make[4]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/uClibc-0.9.33.2'
make[3]:
* /home/bob2/Desktop/openwrt/trunk/build_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/uClibc-0.9.33.2/.built Error 2
make[3]: Leaving directory `/home/bob2/Desktop/openwrt/trunk/toolchain/uClibc'
make[2]: * [toolchain/uClibc/compile] Error 2
make[2]: Leaving directory `/home/bob2/Desktop/openwrt/trunk'
make[1]:
* /home/bob2/Desktop/openwrt/trunk/staging_dir/toolchain-mips_r2_gcc-4.6-linaro_uClibc-0.9.33.2/stamp/.toolchain_install Error 2
make[1]: Leaving directory `/home/bob2/Desktop/openwrt/trunk'
make: * [world] Error 2
bob2@bob-Calistoga-ICH7M-Chipset:~/Desktop/openwrt/trunk$

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by jow

  • Resolution set to worksforme
  • Status changed from new to closed

You need to run "make dirclean" to recompile the toolchain. The above is caused by an incoherent tree.

comment:2 Changed 4 years ago by anonymous

this helps absolutely nothing!!!

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.