Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12263 closed defect (wontfix)

DHCP 4.2.4 not working with Backfire branch

Reported by: prasannar@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Backfire 10.03 RC2
Keywords: Cc: bvalaboj@…

Description

Hi
I observed that Backfire 10.03.2 supports only ISC DHCP 3.x version which is very old. But the trunk version supports ISC DHCP 4.2.4 which is latest, something I would like to use. And I want to use Backfire 10.03.2.

So I downloaded Backfire 10.03.2 and downloaded the open source packages from trunk and compiled for default platform.
Attached is compilation logs of the same.
However,

Attachments (1)

backfireTrunkPkg.txt (8.4 KB) - added by prasannar@… 5 years ago.
ISC DHCP Compilation Logs

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by prasannar@…

ISC DHCP Compilation Logs

comment:1 in reply to: ↑ description Changed 5 years ago by anonymous

Replying to prasannar@…:

Hi
I observed that Backfire 10.03.2 supports only ISC DHCP 3.x version which is very old. But the trunk version supports ISC DHCP 4.2.4 which is latest, something I would like to use. And I want to use Backfire 10.03.2.

So I downloaded Backfire 10.03.2 and downloaded the open source packages from trunk and compiled for default platform.
Attached is compilation logs of the same.

However, upon downloading the trunk and open source packages the compilation for ISC DHCP is successful.

Is it wrong to mix backfire branch and open source packages from trunk?
What should be done to to make ISC DHCP 4.2.4 compile with backfire?

comment:2 Changed 5 years ago by hnyman <hannu.nyman@…>

Backfire is ancient and largely unmaintained. There are no updates to the packages.

If you want to use in Backfire an updated version of a package (that is possibly already updated in trunk), you have to make sure that the Makefile and all the Openwrt-related patches have been modifed to take into account the differences between trunk and Backfire, e.g. totally different kernel version etc.

isc-dhcp looks easy, as there is just one patch in trunk:
https://dev.openwrt.org/browser/packages/net/isc-dhcp/patches

On the other hand, the same package's Bakfire version had more patches, so it might be that the kernel used in Backfire requires more patches.

The result of a succesful compiling may still work buggily, so you have to try spot the possible bugs during usage.

So, it is possible, but not quite easy.

comment:3 Changed 5 years ago by florian

  • Resolution set to wontfix
  • Status changed from new to closed

comment:4 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.