Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12247 closed defect (fixed)

Alex 3d3 with 2 DNMA cards causes Luci to freakout

Reported by: John Schultz <jschultz0614@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Im getting the following error when working with my wifi settings:

for wlan0

/usr/lib/lua/luci/dispatcher.lua:448: Failed to execute arcombine dispatcher target for entry '/admin/network/wireless/radio0.network1'.
The called action terminated with an exception:
/usr/lib/lua/luci/model/cbi/admin_network/wifi.lua:169: bad argument #1 to 'ipairs' (table expected, got nil)
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:448: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

for wlan1

/usr/lib/lua/luci/dispatcher.lua:448: Failed to execute arcombine dispatcher target for entry '/admin/network/wireless/radio1.network1'.
The called action terminated with an exception:
/usr/lib/lua/luci/model/cbi/admin_network/wifi.lua:169: bad argument #1 to 'ipairs' (table expected, got nil)
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:448: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:195: in function </usr/lib/lua/luci/dispatcher.lua:194>

I also can not disable them or edit the props with getting the same error.

Thanks

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by John Schultz <jschultz0614@…>

Jow,.... any ideas?

comment:2 Changed 5 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

This means LuCI was unable to get information from the driver.
Can happen if
a) a type option was set (forced) which is not applicable to the driver
b) the libiwinfo package got compiled without support for the driver in use

If the issue is due to b) then it should be enough to recompile the iwinfo package after enabling the driver kmods used in your firmware. Additional safeguards against the crashes mentioned above have been added in http://luci.subsignal.org/trac/changeset/9326 and http://luci.subsignal.org/trac/changeset/9327

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.