Modify

Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#12220 closed defect (wontfix)

SNMP ifIndex is not constant

Reported by: duvi Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

When the pppoe wan connection reconnects, a new index is created for both the ethernet and pppoe interface in snmp.
This makes it very hard to monitor traffic with snmp.

Package used: snmpd-static - 5.4.2.1-5
Device: TL-WR1043ND (probably does not matter)
Version: r33458 (and ever since netifd)

IF-MIB::ifDescr.15 = STRING: eth0.2
IF-MIB::ifDescr.21 = STRING: eth0.2
IF-MIB::ifDescr.22 = STRING: pppoe-wan
IF-MIB::ifDescr.27 = STRING: eth0.2
IF-MIB::ifDescr.28 = STRING: pppoe-wan
IF-MIB::ifDescr.29 = STRING: eth0.2
IF-MIB::ifDescr.30 = STRING: pppoe-wan

Prior to netifd only the index for pppoe-wan was recreated, eth0.2 was constant. Since netifd eth0.2 index is also recreated on TL-WR1043ND.

On a different device with a dedicated eth port for wan (RB433UAH), only pppoe-wan index is recreated after every reconnection.

IF-MIB::ifDescr.13 = STRING: pppoe-wan
IF-MIB::ifDescr.15 = STRING: pppoe-wan
IF-MIB::ifDescr.16 = STRING: pppoe-wan
IF-MIB::ifDescr.17 = STRING: sixxs
IF-MIB::ifDescr.18 = STRING: pppoe-wan
IF-MIB::ifDescr.19 = STRING: pppoe-wan

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by jow

  • Resolution set to wontfix
  • Status changed from new to closed

Suggest upstream to introduce some kind of custom ifname->ifindex mapping. Relying on kernel ifindexes is broken by design, those are not guaranteed to be stable or meaningful in any way.

If you absolutely need stable ifindex then just use static protocols and do not restart your network.

comment:2 Changed 5 years ago by matt@…

Is there nothing that can be done on the OpenWRT side to fix this issue? This was not a problem before upgrading to Attitude Adjustment. I am using static protocols, however there are numerous reasons that require restarting networking. Whenever I restart networking for one reason or another, I have to restart snmpd and re-configure Cacti.

comment:3 Changed 5 years ago by matt@…

I've switched over to mini-snmpd as an alternative. It properly handles changing interface indexes.

FWIW, I looked into updating the snmpd package to the latest upstream, which supposedly is more resilient to interface index changes. However, it still displayed the same behavior.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:5 Changed 2 years ago by ajaykumar10g@…

i am facing this issue in kamikaze..can any help me..'

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.