Modify

Opened 5 years ago

Closed 3 years ago

#12200 closed defect (moved_to_github)

asterisk-1.8.x with eglibc segementation fault

Reported by: hoowa.sun@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

trunk33444
asterisk-1.8.x
rt3052f
eglibc

can not start asterisk segementation fault!!!!!

Attachments (0)

Change History (14)

comment:1 follow-up: Changed 5 years ago by jow

  • Resolution set to too_vague
  • Status changed from new to closed

Cannot reproduce it in an x86 eglibc build.

comment:2 in reply to: ↑ 1 Changed 5 years ago by anonymous

Replying to jow:

Cannot reproduce it in an x86 eglibc build.

in my enviroment eglibc works in x86 is ok, but in bcm63xx / rt3052f to start asterisk just simple segementation fault, no any other response.

comment:3 Changed 5 years ago by jow

ok, I'll see if I can reproduce it on a qemu build then. Do you use any special configuration or a particular set of plugins? Just "opkg install asterisk18; /etc/init.d/asterisk start" didn't cause any segfault here.

comment:4 Changed 5 years ago by anonymous

uclibc just opkg install asterisk18 to start asterisk is ok.

but eglibc/glibc :-(

i thised on:
HG255D rt3052f
RG100A-AA broadcom6538

not any special configuration.

comment:5 Changed 4 years ago by zouhair.s@…

same problem here on r36346 eglibc + asterisk-1.8.24.0 = Segmentation fault

i need use eGlibc because uClibc 0.9.33.2 is bugy.
/ticket/11929.html <-- with the patch provided here, asterisk work but i get DNS lag ):

comment:6 Changed 4 years ago by anonymous

  • Resolution too_vague deleted
  • Status changed from closed to reopened

comment:7 follow-up: Changed 4 years ago by nbd

please try a newer version of openwrt

comment:8 in reply to: ↑ 7 Changed 4 years ago by zouhair.s@…

Replying to nbd:

please try a newer version of openwrt

which newer version ?
tested with r38435 but not compile: /ticket/14380.html
(the developers of openwrt do not like eglibc) :P

comment:9 follow-up: Changed 4 years ago by nbd

what makes you think openwrt developers don't like eglibc? eglibc is useful, but supporting it doesn't have high priority, because it's too bloated for most devices aynway.

comment:10 in reply to: ↑ 9 Changed 4 years ago by zouhair.s@…

Replying to nbd:

what makes you think openwrt developers don't like eglibc?

the developers do not give much effort to fix the problems related eglibc. They give much more benefit to uClibc.

because it's too bloated for most devices aynway.

Trust me, the new hardware has the right conditions (like memory of flash) for the support ability of this library with iconv/intl included. I love GNU :)

Any idea how to fix this issue #14380 ?
Or solution to compile asterisk-1.8.x full debug with r36346 ? (to fix segfault)
the solution is here https://wiki.asterisk.org/wiki/display/AST/Getting+a+Backtrace but i have no idea how to aply this in openwrt auto build mecanism.

how i enable "DONT_OPTIMIZE / BETTER_BACKTRACES" in asterisk Makefile ? like this ?

   define Build/Compile
        $(MAKE) -C "$(PKG_BUILD_DIR)" \
                include/asterisk/version.h \
                include/asterisk/buildopts.h defaults.h \
                makeopts.embed_rules
                ASTCFLAGS="$(EXTRA_CFLAGS) -DDONT_OPTIMIZE -DBETTER_BACKTRACES

Thanks.

comment:11 Changed 4 years ago by zouhair.s@…

tested with (latest openwrt 14/11/2013) r38800, same problem Segmentation fault.
Asterisk is not work on openwrt using eglibc.

comment:12 Changed 4 years ago by anonymous

additional information:

root@OpenWrt:/# file /usr/sbin/asterisk
/usr/sbin/asterisk: ELF 32-bit MSB executable, MIPS, MIPS32 version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.4.1, with unknown capability 0x41000000 = 0xf676e75, with unknown capability 0x10000 = 0x70403, stripped

root@OpenWrt:/# strace /usr/sbin/asterisk -cvv
execve("/usr/sbin/asterisk", ["/usr/sbin/asterisk", "-cvv"], [/* 5 vars */]) = 0
brk(0)                                  = 0x747000
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x773b1000
uname({sys="Linux", node="OpenWrt", ...}) = 0
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0} ---
+++ killed by SIGSEGV +++
Segmentation fault

comment:13 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:14 Changed 3 years ago by jogo

  • Resolution set to moved_to_github
  • Status changed from reopened to closed

Asterisk is now maintained here: https://github.com/openwrt/telephony.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.