Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12197 closed defect (worksforme)

WRT160NL wifi: 2xAP + STA not working, supported?

Reported by: Lutz.Pressler@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Attitude Adjustment 12.09 Beta
Keywords: Cc:

Description

Is 2x AP SSID + 1 STA interface supported on one ath9k radio (WRT160NL)? 3x AP mode is working, as is AP mode + STA mode, but with
/etc/config/wireless

config wifi-device 'radio0'

option type 'mac80211'
option macaddr 'xx:xx:xx:xx:xx:xx'
option hwmode '11ng'
option htmode 'HT40+'
list ht_capab 'SHORT-GI-40'
list ht_capab 'DSSS_CCK-40'
option disabled 0
option channel 1
option country 'DE'

config wifi-iface

option device 'radio0'
option network 'lan'
option encryption 'psk2'
option ssid 'essid1'
option mode 'ap'
option key 'somekey'
option isolate 0
option ieee80211d 1
option ieee80211w 1

config wifi-iface

option device radio0
option network lan2
option mode ap
option ssid 'essid2'
option encryption 'pskmixed'
option key 'anotherkey'
option hidden 0
option isolate 1
option ieee80211d 1
option ieee80211w 1

config wifi-iface

option device 'radio0'
option mode 'sta'
option ssid 'someessid'
option encryption 'psk2'
option key 'clientkey'
option network 'wan'

wlan0-1 is configured for the essid2 network and enslaved to br-lan, but "ip link" shows NO-CARRIER and state DOWN. essid2 is not visible.

Lutz

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by qasdfdsaq@…

Works for me on WRT160NL (AA Beta r33312):

config wifi-device 'radio0'

option type 'mac80211'
option macaddr '<foo>'
option hwmode '11ng'
list ht_capab 'SHORT-GI-40'
list ht_capab 'DSSS_CCK-40'
option country '00'
option noscan '1'
option channel '1'
option txpower '21'
option disabled '0'

config wifi-iface

option device 'radio0'
option mode 'ap'
option ssid 'essid1'
option encryption 'psk2+ccmp'
option key 'random shiznit'
option network 'lan'
option wmm '0'

config wifi-iface

option device 'radio0'
option mode 'ap'
option ssid 'essid2'
option encryption 'psk+ccmp'
option key 'random shiznit'
option network 'lan'
option wmm '0'

config wifi-iface

option ssid 'essid3'
option encryption 'none'
option device 'radio0'
option mode 'sta'
option network 'wan'

# option bssid '<bar>'

I've also used multiple AP + STA + WDS setups on other ath9k routers many times.

comment:2 Changed 5 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

should be working fine on recent versions. if not, please provide the output of ifconfig/iwconfig and the exact revision that you're using.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.