Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12186 closed defect (worksforme)

STA stopped working after build r33311

Reported by: mikejuni@… Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

STA in AR71xx stopped working after build r33311. I've a working self-build on r33311 which works perfectly fine. My setup is like below:

router a router b

pppoe -- ar71xx ap (wds) -- ar71xx sta (wds) + ap

Router b stopped connecting to router somewhere after this build. I tried to disable the ap in router b and it resumes. However it no longer help me extend the range of the wifi hence it is useless.

Attachments (3)

network (939 bytes) - added by mikejuni@… 5 years ago.
network configuration
wireless (1.5 KB) - added by mikejuni@… 5 years ago.
My wireless config for the non-working router.
Capture r33595.png (54.5 KB) - added by mikejuni@… 5 years ago.
Capture of screen of issue.

Download all attachments as: .zip

Change History (25)

comment:1 Changed 5 years ago by nbd

Please track down in what approximate revision this error was introduced.

comment:2 Changed 5 years ago by anonymous

It was introduced with r33311, thanks!

comment:3 Changed 5 years ago by nbd

But didn't you say you have a working build on r33311?

comment:4 Changed 5 years ago by mikejuni@…

All my OpenWRT routers having r33311 and it is working fine.

comment:5 Changed 5 years ago by nbd

OK, please find out which version the error first appeared in.

comment:6 Changed 5 years ago by mikejuni@…

I use svn co svn://svn.openwrt.org/openwrt/trunk/@33325 to checkout @33325 from trunk and build an image. Suspect it is where the problem lies (it is when a new version of netifd is released).

The problem did occur in @33325. I think it is where the problem lies since all patches between 33311 and 33325 aren't so related to ar71xx.

However, when I use scripts/getver.sh it shows that I'm at 33353. Not sure why it isn't 33325...

Let me know if my svn command isn't correct.

comment:7 Changed 5 years ago by nbd

please post your network and wireless config

Changed 5 years ago by mikejuni@…

network configuration

Changed 5 years ago by mikejuni@…

My wireless config for the non-working router.

comment:8 Changed 5 years ago by mikejuni@…

My non-working router's configuration attached.

comment:9 Changed 5 years ago by nbd

  • Priority changed from normal to response-needed

please try latest trunk

comment:10 Changed 5 years ago by mikejuni@…

Doesn't work. Just tried the version with netifd patch (r33595)

Changed 5 years ago by mikejuni@…

Capture of screen of issue.

comment:11 Changed 5 years ago by mikejuni@…

Just some additional information. I've actually 3 Openwrt routers. 1 wndr3700 and 2 ag300h

The wndr3700 is my primary pppoe router.

wndr3700 (wds ap)
| |
ag300h ag300h
(ap + wds sta) (ap + wds sta)

As you can see the configuration is to extend my wndr3700's range.

The configuration of both ag300h is the same (except ip address / macaddr, etc). Only difference is that one is on r33311 and the other one now on r33595.

In the one for r33595 I got the error captured above, and it cannot connect to the wds ap while the other one can. If I remove the "ap" portion of the configuration it can connect to the netgear, but it is useless because I cannot extend the range without "ap" configuration.

comment:12 Changed 5 years ago by mikejuni@…

Sorry the above diagram isn't showing it right.

It is something like this:

ag300h (ap + wds sta) --- wndr3700 (wds ap, pppoe) --- ag300h (ap + wds sta)

comment:13 Changed 5 years ago by mikejuni@…

This is still bugging me as of today's build (r33669)

comment:14 Changed 5 years ago by mikejuni@…

Today I use the "wifi" command manually and it reveals an additional error message:

Failed to set up wpa_supplicant for interface wlan1-1

And I checked ifconfig and noticed that wlan1-1 is not being brought up when using wds sta + ap in the latest builds.

comment:15 Changed 5 years ago by nbd

Please show me the contents of /var/run/wpa_supplicant-wlan1-1.conf

Are there no other messages just before "Failed to set up wpa_supplicant for interface wlan1-1"

Does that error message go away if you explicitly do wifi down; wifi?

comment:16 Changed 5 years ago by mikejuni@…

Contents of /var/run/wpa_supplicant-wlan1-1.conf

ctrl_interface=/var/run/wpa_supplicant-wlan1-1

network={
	
	scan_ssid=1
	ssid="OBLLNTKJ30"
	bssid=aa:bb:cc:dd:ee:ff
	key_mgmt=WPA-PSK
	proto=RSN
	
	fixed_freq=1
	
	
	
	
	
	psk="password"
	
	
	

Where aa:bb:cc:dd:ee:ff is the BSSID of my WDS AP (The Internet router) and password is the password to the ssid obllntkj30. The full error messages are:

command failed: Device or resource busy (-16)
Configuration file: /var/run/hostapd-phy1.conf
Successfully initialized wpa_supplicant

Failed to connect to hostapd

enable_mac80211(radio1): Failed to set up wpa_supplicant for interface wlan1-1

comment:17 Changed 5 years ago by mikejuni@…

I just got some more information, I noticed that apart from wpa_supplicant-wlan1-1.conf, there is also a file wpa_supplicant-wlan1.conf. wlan1 is supposed to be the AP interface. wlan1 do seems to work because I could actually connect to it (but without DHCP address as it is disabled).

Not sure if it is supposed to exist or not.

comment:18 Changed 5 years ago by mikejuni@…

Issue still exist. Same error message as of today's build.

comment:19 Changed 5 years ago by mikejuni@…

Just want to follow up on this issue, any news? I'm still having this error. It seems like wlan1-1 cannot be brought up causing this, but I'm not sure.

comment:20 Changed 5 years ago by mikejuni@…

I've managed to fixed the issue after digging into mac80211.sh for a while and upgrading to latest trunk (with kernel 3.6.8). It seems like there is some issue with the script preventing it from creating 2 interfaces on same PHY without specifying in /etc/config/wireless the ifname for the device.

Once I've put in the the following options:

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option wds '0'
	option ssid 'ssid'
	option encryption 'psk2+ccmp'
	option key 'password'
	option ifname 'wlan1'
	option disabled 0

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'sta'
	option ssid 'ssid'
	option encryption 'psk2+ccmp'
	option key 'password'
	option wds '1'
	option ifname 'wlan1-1'
	option bssid 'aa:bb:cc:dd:ee:ff'

Note the "ifname" option (which is not in any documentation) I've managed to bring both the STA and the AP up. However, it doesn't seem like this is a documented option. Also, the script should be able to bring up additional interface if needed.

comment:21 Changed 5 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

doesn't seem like an issue in current trunk anymore.

comment:22 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.