Modify

Opened 11 years ago

Closed 10 years ago

#1218 closed defect (invalid)

madwifi init error: ath_pci: cannot reserve PCI memory region

Reported by: axel@… Owned by: developers
Priority: normal Milestone:
Component: kernel Version:
Keywords: ath_pci PCI memory Cc:

Description

On my WGT634U using kamikaze r6131 the ath_pci module does not successfully load.
In detail dmesg says:
...
PPP generic driver version 2.4.2
wlan: 0.8.4.2 (0.9.2.1)
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413, REGO)
ath_rate_sample: 1.2 (0.9.2.1)
wlan: mac acl policy registered
ath_pci: 0.9.4.5 (0.9.2.1)
PCI: Fixing up device 0000:01:01.0
ath_pci: cannot reserve PCI memory region

However, with the last buildroot-ng r4953 this was not a problem. I checked this with two different cards one bg and one abg.
The old buildroot-ng r4953 shows:
<6>wlan: 0.8.4.2 (0.9.2)
<4>ath_hal: module license 'Proprietary' taints kernel.
<6>ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413, REGOPS_FUNC)
<6>ath_rate_sample: 1.2 (0.9.2)
<6>wlan: mac acl policy registered
<6>ath_pci: 0.9.4.5 (0.9.2)
<4>PCI: Enabling device 0000:01:01.0 (0000 -> 0002)
<4>PCI: Fixing up device 0000:01:01.0
<6>ath_pci: switching rfkill capability off
<4>wifi0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
<4>wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>wifi0: turboA rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
<4>wifi0: H/W encryption support: WEP AES AES_CCM TKIP
<4>wifi0: mac 5.9 phy 4.3 radio 3.6
<4>wifi0: Use hw queue 1 for WME_AC_BE traffic
<4>wifi0: Use hw queue 0 for WME_AC_BK traffic
<4>wifi0: Use hw queue 2 for WME_AC_VI traffic
<4>wifi0: Use hw queue 3 for WME_AC_VO traffic
<4>wifi0: Use hw queue 8 for CAB traffic
<4>wifi0: Use hw queue 9 for beacons
<6>wifi0: Atheros 5212: mem=0x40010000, irq=2

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by axel@…

Hello,

Update: My mistake, seems to be a HW problem, sorry for any inconvenience

I figured out that the problem described above is actually a hardware problem since it only appears with one specific out of two identical (WGT634U) HW plattforms. Since the exact reason is still unclear to me any hints are welcome.

regards,
axel

comment:2 Changed 11 years ago by nbd

  • Resolution set to worksforme
  • Status changed from new to closed

comment:3 Changed 10 years ago by kasemodz@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I'm having the same problem yet I don't know the different hw revision for this platform anyone know?

comment:4 Changed 10 years ago by florian

  • Resolution set to invalid
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.