Modify

Opened 5 years ago

Closed 5 years ago

#12177 closed defect (worksforme)

Pin code on 3G connection

Reported by: dannyf@… Owned by:
Priority: normal Milestone: Bugs Paradise
Component: luci Version: 10.03.1
Keywords: 3G/GPRS Cc:

Description

I'm trying to setup an OpenWRT router with a 3G/GPRS connection but i'm having some trouble setting the wan interface via web (I use Luci). If you try to use a pincode with more than 4 digits the webinterface doesn't allow you to safe and/or apply the changes. You have to set the pincode manually editing the /etc/config/network file via ssh and setting the pincode there. If you access que settings page of the 3G/GPSR connection you have a mark in the line of the pincode to indicate it's not correctly set.
Thanks

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 5 years ago by dannyf@…

  • Resolution fixed deleted
  • Status changed from closed to reopened

I've been investigating about this resolution en the file /usr/lib/lua/luci/model/cbi/admin_network/proto_3g.lua has the updated line "pincode.datatype = "range(0,9999)" ". I also tried to reinstall the package, but y sill get the same error as before.

http://imageshack.us/photo/my-images/211/capturadepantalla201209ve.png/

Is it possible that the problem is somewhere else.
Thanks

comment:3 Changed 5 years ago by jow

  • Resolution set to worksforme
  • Status changed from reopened to closed

There is no updated line, it should be removed entirely.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.