Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12131 closed defect (invalid)

failed to run sqlite3 on openwrt system.

Reported by: jameslord Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version: Backfire 10.03.1 RC2
Keywords: SQLite hend ader asource version mismatch Cc: hans.zandbelt@…

Description

root@OpenWrt:~/dsk# cd db/
root@OpenWrt:~/dsk/db# ls
root@OpenWrt:~/dsk/db# sqlite3 db1
SQLite header and source version mismatch
2010-07-20 20:23:38 13ed106c8c279422a6159e28c6887d13a88b7b8b
2011-06-28 17:39:05 af0d91adf497f5f36ec3813f04235a6e195a605f

more details are as follows:

root@OpenWrt:/proc# opkg list | grep sqlite
freeradius2-mod-sql-sqlite - 2.1.10-2 - SQLite module
libsqlite2 - 2.8.17-2 - SQLite is a small C library that implements a self-contained, embeddable,
libsqlite3 - 3070701-1 - SQLite is a small C library that implements a self-contained, embeddable,
libsqlite3 - 3.7.0-1
lsqlite3 - 7-2 - LuaSQLite 3 is a thin wrapper around the public domain SQLite3 database engine.
luasql-sqlite3 - 2.1.1-1 - LuaSQL is a simple interface from Lua to a DBMS.
nfacctd-sqlite - 0.12.5-1 - NetFlow accounting daemon with SQLite support
php5-mod-pdo-sqlite - 5.3.6-3 - PDO driver for SQLite 3.x shared module
php5-mod-sqlite - 5.3.6-3 - SQLite 2.x shared module
php5-mod-sqlite3 - 5.3.6-3 - SQLite3 shared module
pmacctd-sqlite - 0.12.5-1 - IP pcap-based accounting daemon with SQLite support
python-sqlite - 2.3.5-1 - This package contains an SQLite database adapter for the Python
python-sqlite3 - 2.6.4-3 - Python support for sqlite3
qt4-sqlite - 4.7.0-1 - qt4 (sqlite)
sqlite2-cli - 2.8.17-2 - SQLite is a small C library that implements a self-contained, embeddable,
sqlite3-cli - 3070701-1 - SQLite is a small C library that implements a self-contained, embeddable,
strongswan4-mod-sqlite - 4.5.2-1 - StrongSwan SQLite database interface plugin
uacctd-sqlite - 0.12.5-1 - IP pcap-based accounting daemon with SQLite support
ulogd-mod-sqlite - 1.24-1 - Output plugin for logging to an SQLite database

root@OpenWrt:/proc# opkg list-installed | grep sqlite
libsqlite3 - 3.7.0-1
root@OpenWrt:/proc# opkg install sqlite3-cli
Installing sqlite3-cli (3070701-1) to root...
Downloading http://downloads.openwrt.org/backfire/10...m63xx.ipk.
Collected errors:

root@OpenWrt:/proc# opkg update
Downloading http://downloads.openwrt.org/backfire/10...ckages.gz.
Inflating http://downloads.openwrt.org/backfire/10...ckages.gz.
Updated list of available packages in /var/opkg-lists/snapshots.
root@OpenWrt:/proc# opkg install sqlite3-cli
Installing sqlite3-cli (3070701-1) to root...
Downloading http://downloads.openwrt.org/backfire/10...m63xx.ipk.
Configuring sqlite3-cli.

root@OpenWrt:~/dsk# cd db/
root@OpenWrt:~/dsk/db# ls
root@OpenWrt:~/dsk/db# sqlite3 db1
SQLite header and source version mismatch
2010-07-20 20:23:38 13ed106c8c279422a6159e28c6887d13a88b7b8b
2011-06-28 17:39:05 af0d91adf497f5f36ec3813f04235a6e195a605f

root@OpenWrt:~/dsk/db# opkg remove libsqlite3 - 3.7.0-1
No packages removed.
Collected errors:

  • print_dependents_warning: Package libsqlite3 is depended upon by packages:
  • print_dependents_warning: libaprutil
  • print_dependents_warning: sqlite3-cli
  • print_dependents_warning: These might cease to work if package libsqlite3 is removed.
  • print_dependents_warning: Force removal of this package with --force-depends.
  • print_dependents_warning: Force removal of this package and its dependents
  • print_dependents_warning: with --force-removal-of-dependent-packages.

root@OpenWrt:~/dsk/db# opkg remove libsqlite3
No packages removed.
Collected errors:

  • print_dependents_warning: Package libsqlite3 is depended upon by packages:
  • print_dependents_warning: libaprutil
  • print_dependents_warning: These might cease to work if package libsqlite3 is removed.
  • print_dependents_warning: Force removal of this package with --force-depends.
  • print_dependents_warning: Force removal of this package and its dependents
  • print_dependents_warning: with --force-removal-of-dependent-packages.

root@OpenWrt:~/dsk/db# opkg info libaprutil
Package: libaprutil
Version: 1.3.12-1
Depends: libapr, libexpat, libsqlite3, libuuid
Provides:
Status: unknown ok not-installed
Section: libs
Architecture: brcm63xx
Maintainer: OpenWrt Developers Team <openwrt-devel@…>
MD5Sum: 26cdcc12ec1e7d897925f674054e7b3c
Size: 55267
Filename: libaprutil_1.3.12-1_brcm63xx.ipk
Source: feeds/packages/libs/apr-util
Description: Apache Portable Runtime Utility Library

Package: libaprutil
Version: 1.3.9-1
Depends: libapr, libexpat, libiconv, libpthread, libsqlite3, libuuid
Provides:
Status: install ok installed
Architecture: brcm63xx
Installed-Time: 1303507058

cat /etc/banner

_

| |.-----.-----.-----.| | | |.----.| |_

| - |_
_ | -| | | _ _|
|_||| ||

|| W I R E L E S S F R E E D O M

Backfire (10.03, r26172) --------------------------

  • 1/3 shot Kahlua In a shot glass, layer Kahlua
  • 1/3 shot Bailey's on the bottom, then Bailey's,
  • 1/3 shot Vodka then Vodka.

---------------------------------------------------

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

Library and cli util are different versions.

comment:2 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.