Modify

Opened 5 years ago

Last modified 4 years ago

#12087 new defect

cryptsetup package dependencies overly broad

Reported by: thegrugq@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: cryptsetup lvm2 Cc:

Description

The cryptsetup package has a dependency on LVM2 which is unnecessary. On space constrained devices this causes problems as the LVM2 package is relatively large.

I've been manually editing the Packages file to remove the 'lvm2' dependency to cryptsetup without negative effect. It would be nice if this was the default, however. Any user who wants lvm2 support can install that package separately.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.