Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12072 closed defect (fixed)

tor crashes with Assertion `md_c[1] == md_count[1]' failed.

Reported by: Leonid Evdokimov <leon@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: tor openssl Cc:

Description

...
Aug 24 00:43:13.842 [notice] Performing bandwidth self-test...done.
/usr/sbin/tor: md_rand.c: 325: ssleay_rand_add: Assertion `md_c[1] == md_count[1]' failed.
Aborted
root@OpenWrt:~# opkg list-installed | grep 'tor \|ssl '
libopenssl - 1.0.1c-1
tor - 0.2.2.37-1

Sort of duplicate of #9036

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by jow

  • Resolution set to fixed
  • Status changed from new to closed

see r33269

comment:2 Changed 5 years ago by Leonid Evdokimov <leon@…>

Does it make sense to have both

OPENSSL_OPTIONS:= ... no-threads

and

TARGET_CFLAGS += ... -DOPENSSL_THREADS -pthread -D_REENTRANT -D_THREAD_SAFE -D_THREADSAFE

It looks a bit weird. I assume, it may required by cross-compilation, but strange "rm" at Build/Compile is commented as a workaround for some bug and this hack is not.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.