Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#12071 closed defect (invalid)

x86: upgrade broken

Reported by: Erik Fonnesbeck <efonnes@…> Owned by: acinonyx
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: base system Version: Trunk
Keywords: Cc:

Description

Upgrade on x86 has been broken for a while now in trunk (tested with squashfs image on generic profile). It seems to do nothing at all except for a reboot.

For a while I have just been working around the issue by manually copying the images and restoring config after, but I have not dared upgrade my non-x86 devices because I was not sure if it was specific to x86, so I decided to look into it myself.

Tracing the scripts to find where it writes the image to disk, I found a line in /lib/upgrade/platform.sh that uses dd to do the write. Attempting to run the command manually would just display the help text for dd, so I figured a parameter must be wrong. Looking through the help text, I did not see the 'conv' parameter listed as supported for the installed dd command, so I tried removing the conv=fsync parameter. The image write succeeded so I tried making that change to the script, which made upgrading work again.

For reference, r32465 introduced the modified line using the dd command with the unsupported parameter.

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by anonymous

Shouldn't it be "conv=sync" instead of "conv=fsync" ?

comment:2 Changed 5 years ago by Erik Fonnesbeck <efonnes@…>

Trying various options for conv, that parameter does not seem to be supported at all by the included dd.

comment:3 Changed 5 years ago by acinonyx

  • Owner changed from developers to acinonyx
  • Priority changed from normal to response-needed
  • Status changed from new to accepted

See the previous r32464 change. It enables 'conv' option on busybox dd.

Please check that your busybox configuration is updated.

comment:4 Changed 5 years ago by Erik Fonnesbeck <efonnes@…>

I thought I had already recreated my config from scratch recently, but apparently not. I recreated my build config starting at the defaults again and now dd does report conv as supported (along with the fsync option for conv) and the upgrade no longer fails.

comment:5 Changed 5 years ago by jow

  • Resolution set to invalid
  • Status changed from accepted to closed

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.