Modify

Opened 5 years ago

Last modified 4 years ago

#12044 new enhancement

Bluez packages for OpenWRT don't include hidd

Reported by: Paul Sokolovsky <pmiscml@…> Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

On Backfire (10.03.1, r29592):

# opkg files bluez-utils
Package bluez-utils (3.36-7) is installed on root and has the following files:
/etc/init.d/bluez-utils
/etc/bluetooth/hcid.conf
/usr/sbin/hcid
/usr/bin/pand
/usr/bin/ciptool
/usr/sbin/hciattach
/usr/bin/l2ping
/usr/bin/dund
/usr/bin/hcitool
/etc/bluetooth/rfcomm.conf
/usr/bin/sdptool
/etc/dbus-1/system.d/bluetooth.conf
/usr/sbin/hciconfig
/etc/config/bluetooth
/usr/bin/rfcomm

No hidd, which is required to connect Bluetooth HID devices, which in turn required for remote control application usings routers and just for human interaction for devices with screens, etc.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Paul Sokolovsky <pmiscml@…>

comment:2 Changed 5 years ago by Paul Sokolovsky <pmiscml@…>

The questions now how to fix it properly. I personally don't want to call for blame from people who may install bluez-utils in scarce ROM space and break their setups with adding another daemon which their so far didn't need. So, it call for adding another package "bluez-hidd" (then maybe another "bluez-audio", etc.)

comment:3 Changed 4 years ago by jow

  • Milestone changed from Backfire 10.03.2 to Chaos Calmer (trunk)

Milestone Backfire 10.03.2 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.