Modify

Opened 5 years ago

Closed 3 years ago

#12018 closed defect (invalid)

sta+ap problem

Reported by: tha_voldemort@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi,
I downloaded today's version of OpenWRT on my TL wr740n v4.22, and tried to configure it into sta+ap mode - without success. after restart second interface is properly created (wlan0-1) and ap network is visible in ether for a few seconds. sta interface works normally - connects to other AP, the problem is with ap.
when I configure sta+ap, I get following message after restart:

root@OpenWrt:/etc/config# /etc/init.d/network restart
command failed: Device or resource busy (-16)
Configuration file: /var/run/hostapd-phy0.conf
Using interface wlan0 with hwaddr 90:f6:52:a3:01:d0 and ssid 'test'
random: Cannot read from /dev/random: Resource temporarily unavailable
random: Only 0/20 bytes of strong random data available from /dev/random
random: Not enough entropy pool available for secure operations
WPA: Not enough entropy in random pool for secure operations - update keys later when the first station connects

I am posting also results of ifconfig and contents of my wireless and network files

root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 90:F6:52:A3:01:CF
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:766 errors:0 dropped:62 overruns:0 frame:0
          TX packets:401 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:107250 (104.7 KiB)  TX bytes:148770 (145.2 KiB)

eth0      Link encap:Ethernet  HWaddr 90:F6:52:A3:01:CF
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:817 errors:0 dropped:14 overruns:0 frame:0
          TX packets:409 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:123708 (120.8 KiB)  TX bytes:149406 (145.9 KiB)
          Interrupt:5

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1364 (1.3 KiB)  TX bytes:1364 (1.3 KiB)

wlan0     Link encap:Ethernet  HWaddr 90:F6:52:A3:01:D0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:0 (0.0 B)  TX bytes:3208 (3.1 KiB)

wlan0-1   Link encap:Ethernet  HWaddr 92:F6:52:A3:01:D1
          inet addr:192.168.22.192  Bcast:192.168.22.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:339 errors:0 dropped:0 overruns:0 frame:0
          TX packets:353 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:140984 (137.6 KiB)  TX bytes:82079 (80.1 KiB)

root@OpenWrt:~#
root@OpenWrt:root@OpenWrt:/etc/config# cat wireless
config wifi-device  radio0
        option type     mac80211
        option channel  11
        option macaddr  90:f6:52:a3:01:d0
        option hwmode   11ng
        option htmode   HT20
        list ht_capab   SHORT-GI-20
        list ht_capab   SHORT-GI-40
        list ht_capab   RX-STBC1
        list ht_capab   DSSS_CCK-40
        # REMOVE THIS LINE TO ENABLE WIFI:
        # option disabled 1

config wifi-iface 'ap'
        option device   radio0
        option network  wan
        option mode     sta
        option ssid     Gargoyle
        option encryption psk2
        option key      JulciaJulcia

config wifi-iface 'app'
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     test
        option encryption psk2
        option key      haslohaslo

root@OpenWrt:/etc/config#
root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
#       option ifname 'eth1'

        option proto 'dhcp'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4'

root@OpenWrt:/etc/config#

Regards,
Łukasz Sz.

Attachments (0)

Change History (8)

comment:1 Changed 5 years ago by anonymous

STA+AP problem appear again.
Previous ticket has been deleted, what's going on !?

comment:2 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r33311

comment:3 Changed 5 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Has it been solved - I've just installed (Bleeding Edge, r33288) and situation is the same like for preprevious trunk release (middle of august). After creating a VAP and restarting network, two radio interfaces are visible (ifconfig command) router connects to AP, but no wifi with name defined in /etc/config/wireless is visible in the ether.

comment:4 Changed 5 years ago by anonymous

OK, sorry - I have not noticed annotation that it was fixed it later release than I installed, btw is this version (r33311) availible for downloading? If no when will it be?
Regards,
Łukasz

comment:5 Changed 5 years ago by jow

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:7 Changed 3 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hi Everyone,
I am working on openWRT Luci, able to change the settings in the file under :/etc/config/ and settings will get change, but when I do factory reset from GUI, All the changes i have done in script file gone. So I need to know from which this all factory reset configuration is loading so that I will change it that file my default configuration.

So that after factory reset it should with my default settings.

Thanks,
John

comment:8 Changed 3 years ago by cyrus

  • Resolution set to invalid
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.