Modify

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#11985 closed defect (wontfix)

No low-speed usb device support on TL-MR3020

Reported by: andreas.gaertig@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: usb, ehci, hid Cc:

Description

Directly attached low speed usb device are not detected on TP-MR3020 an producing the following error "connect-debounce failed" in the kernel error log.

If the same device is connected through a usb hub, everything works fine (log lines with 1933).

The low speed device is in this special case a Oregon Scientific Weather Station which works as a hid device. For testing every usb keyboard should reproduce the error.

Tried with many older trunk versions and the current one r32991.

root@openwrt:/tmp# dmesg
[ 1751.430000] hub 1-0:1.0: connect-debounce failed, port 1 disabled
[ 1753.830000] hub 1-0:1.0: connect-debounce failed, port 1 disabled
[ 1756.230000] hub 1-0:1.0: connect-debounce failed, port 1 disabled
[ 1758.630000] hub 1-0:1.0: connect-debounce failed, port 1 disabled
[ 1761.030000] hub 1-0:1.0: connect-debounce failed, port 1 disabled
[ 1763.430000] hub 1-0:1.0: connect-debounce failed, port 1 disabled
[ 1765.830000] hub 1-0:1.0: connect-debounce failed, port 1 disabled
[ 1768.230000] hub 1-0:1.0: connect-debounce failed, port 1 disabled
[ 1770.630000] hub 1-0:1.0: connect-debounce failed, port 1 disabled

[ 1933.450000] usb 1-1: new high-speed USB device number 2 using ehci-platform
[ 1933.600000] hub 1-1:1.0: USB hub found
[ 1933.600000] hub 1-1:1.0: 4 ports detected
[ 1933.900000] usb 1-1.3: new low-speed USB device number 3 using ehci-platform

root@openwrt:/tmp#  cat /proc/cpuinfo 
system type             : Atheros AR9330 rev 1
machine                 : TP-LINK TL-MR3020
processor               : 0
cpu model               : MIPS 24Kc V7.4
BogoMIPS                : 265.42
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 4, address/irw mask: [0x0000, 0x0ff8, 0x0ff8, 0x0ff8]
ASEs implemented        : mips16
shadow register sets    : 1
kscratch registers      : 0
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

Attachments (0)

Change History (9)

comment:1 follow-up: Changed 5 years ago by Nilfred <nilfred@…>

Not a bug, Luke:

okpg install kmod-usb-ohci kmod-usb-hid 

comment:2 Changed 5 years ago by anonymous

EHCI controllers are packaged wit "companion" host controller (OHCI or UHCI) to handle USB1.1 devices connected to root hub ports

comment:3 in reply to: ↑ 1 Changed 5 years ago by andreas.gaertig@…

Replying to Nilfred <nilfred@…>:

Not a bug, Luke:

okpg install kmod-usb-ohci kmod-usb-hid 

The ohci_hcd kernel module was of course loaded beside the ehci_hcd module. The kmod-usb-hid package is in my special case not needed, because I'm using my own libusb based hid driver. But my hid driver can't see the device, because of a lower layer problem.

root@openwrt:~# lsmod | grep ohci
ohci_hcd               16240  0 
usbcore               104514  7 pl2303,ftdi_sio,usbserial,ohci_hcd,ledtrig_usbdev,ehci_hcd
root@openwrt:~# lsmod | grep ehci
ehci_hcd               33008  0 
usbcore               104514  7 pl2303,ftdi_sio,usbserial,ohci_hcd,ledtrig_usbdev,ehci_hcd

comment:4 Changed 5 years ago by nbd

  • Resolution set to wontfix
  • Status changed from new to closed

There is no "companion" host controller on this device, it only has EHCI, no OHCI or UHCI. This issue is a hardware limitation, not a software one.

comment:5 Changed 5 years ago by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:6 Changed 5 years ago by nbd

  • Resolution set to wontfix
  • Status changed from reopened to closed

comment:7 Changed 5 years ago by simon.tretter@…

Same problem here with a V-USB based device. Any ideas how to get around it?

comment:8 Changed 5 years ago by anonymous

@Simon: The only fix is to attach a USB 2.0 captable USB hub (see Wiki TP-Link TL-MR3020#usb.port.and.monitoring.serial.console.via.usb-serial)

comment:9 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.