Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#11978 closed defect (invalid)

noscan invaild

Reported by: msxcms Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: noscan invaild Cc:

Description

In my MW4530R(hardware likes WDR4310), I can't get 2.4G working on 40Mhz, my laptop only get 54Mbps. but 5Ghz can working on 40Mhz normally.
option noscan have added to the wireless config file.

trunk r32930

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by anonymous

look like 802.11ng enable failed, only works on 802.11g.

comment:2 Changed 5 years ago by nbd

  • Resolution set to too_vague
  • Status changed from new to closed

such vague problem descriptions are useless unless you post your full configuration. in this case it looks like a configuration error.
feel free to reopen with more details if the problem persists.

comment:3 Changed 5 years ago by msxcms <msxcms@…>

  • Resolution too_vague deleted
  • Status changed from closed to reopened

hello, there is my /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option macaddr 'ec:17:xx:xx:xx:f8'
	option hwmode '11ng'
	list ht_capab 'LDPC'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option channel '1'
	option txpower '20'
	option htmode 'HT40+'
	option country 'US'
	option noscan '1'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'myssid'
	option wmm '0'
	option encryption 'psk2+ccmp'
	option key 'mypwd'

config wifi-device 'radio1'
	option type 'mac80211'
	option macaddr 'ec:17:xx:xx:xx:f9'
	option hwmode '11na'
	list ht_capab 'LDPC'
	list ht_capab 'SHORT-GI-20'
	list ht_capab 'SHORT-GI-40'
	list ht_capab 'TX-STBC'
	list ht_capab 'RX-STBC1'
	list ht_capab 'DSSS_CCK-40'
	option txpower '17'
	option htmode 'HT40+'
	option country 'US'
	option noscan '1'
	option channel '149'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'myssid'
	option encryption 'psk2+ccmp'
	option key 'mypwd'


there is some debug information

root@openwrt:~# cat /sys/kernel/debug/ieee80211/phy0/channel_type
ht40+
root@openwrt:~# grep -i ht /sys/kernel/debug/ieee80211/phy0/ath9k/*_eeprom -r
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 2GHz HT20 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 2GHz HT40 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 5Ghz HT20 :          0
/sys/kernel/debug/ieee80211/phy0/ath9k/base_eeprom:   Disable 5Ghz HT40 :          0

root@openwrt:~# iw phy0 info
Wiphy phy0
        Band 1:
                Capabilities: 0x11ef
                        RX LDPC
                        HT20/HT40
                        SM Power Save disabled
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15
                Frequencies:
                        * 2412 MHz [1] (27.0 dBm)
                        * 2417 MHz [2] (27.0 dBm)
                        * 2422 MHz [3] (27.0 dBm)
                        * 2427 MHz [4] (27.0 dBm)
                        * 2432 MHz [5] (27.0 dBm)
                        * 2437 MHz [6] (27.0 dBm)
                        * 2442 MHz [7] (27.0 dBm)
                        * 2447 MHz [8] (27.0 dBm)
                        * 2452 MHz [9] (27.0 dBm)
                        * 2457 MHz [10] (27.0 dBm)
                        * 2462 MHz [11] (27.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
                Bitrates (non-HT):
                        * 1.0 Mbps
                        * 2.0 Mbps (short preamble supported)
                        * 5.5 Mbps (short preamble supported)
                        * 11.0 Mbps (short preamble supported)
                        * 6.0 Mbps
                        * 9.0 Mbps
                        * 12.0 Mbps
                        * 18.0 Mbps
                        * 24.0 Mbps
                        * 36.0 Mbps
                        * 48.0 Mbps
                        * 54.0 Mbps
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        Coverage class: 0 (up to 0m)
        Supported Ciphers:
                * WEP40 (00-0f-ac:1)
                * WEP104 (00-0f-ac:5)
                * TKIP (00-0f-ac:2)
                * CCMP (00-0f-ac:4)
                * CMAC (00-0f-ac:6)
        Available Antennas: TX 0x3 RX 0x3
        Configured Antennas: TX 0x3 RX 0x3
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * WDS
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
        software interface modes (can always be added):
                 * AP/VLAN
                 * monitor
        valid interface combinations:
                 * #{ managed, WDS, P2P-client } <= 2048, #{ IBSS, AP, mesh point, P2P-GO } <= 8,
                   total <= 2048, #channels <= 1
        Supported commands:
                 * new_interface
                 * set_interface
                 * new_key
                 * new_beacon
                 * new_station
                 * new_mpath
                 * set_mesh_params
                 * set_bss
                 * authenticate
                 * associate
                 * deauthenticate
                 * disassociate
                 * join_ibss
                 * join_mesh
                 * remain_on_channel
                 * set_tx_bitrate_mask
                 * action
                 * frame_wait_cancel
                 * set_wiphy_netns
                 * set_channel
                 * set_wds_peer
                 * Unknown command (82)
                 * Unknown command (81)
                 * Unknown command (84)
                 * Unknown command (87)
                 * Unknown command (85)
                 * connect
                 * disconnect
        Supported TX frame types:
                 * IBSS: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * managed: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * AP: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * AP/VLAN: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * mesh point: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * P2P-client: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
                 * P2P-GO: 0x0000 0x0010 0x0020 0x0030 0x0040 0x0050 0x0060 0x0070 0x0080 0x0090 0x00a0 0x00b0 0x00c0 0x00d0 0x00e0 0x00f0
        Supported RX frame types:
                 * IBSS: 0x00b0 0x00c0 0x00d0
                 * managed: 0x0040 0x00d0
                 * AP: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
                 * AP/VLAN: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
                 * mesh point: 0x00b0 0x00c0 0x00d0
                 * P2P-client: 0x0040 0x00d0
                 * P2P-GO: 0x0000 0x0020 0x0040 0x00a0 0x00b0 0x00c0 0x00d0
        Device supports RSN-IBSS.
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        Device supports TX status socket option.
        Device supports HT-IBSS.


in all my devices, the radio0 only works on 54Mbps 20Mhz, LUCI shows the max RX&TX Rate 54Mbit/s 20MHz, but radio1 can works on 300Mbps(my Intel N6205 have 2x2MIMO only). The factory firmware works on 2.4Ghz 300Mbps without any question.

comment:4 follow-up: Changed 5 years ago by anonymous

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'myssid'
	option wmm '0'
	option encryption 'psk2+ccmp'
	option key 'mypwd'

try setting wmm to '1'. I think it's required by 802.11n.

comment:5 in reply to: ↑ 4 Changed 5 years ago by msxcms <msxcms@…>

Replying to anonymous:

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'myssid'
	option wmm '0'
	option encryption 'psk2+ccmp'
	option key 'mypwd'

try setting wmm to '1'. I think it's required by 802.11n.

It's effective. The automatic generated file set it to 0, set it to 1 is useful.
According to http://wiki.openwrt.org/doc/uci/wireless, i thought default value should be 0 and ignored this option.

Thanks!

comment:6 Changed 5 years ago by nbd

  • Resolution set to invalid
  • Status changed from reopened to closed

The automatically generated file did not include this option. I fixed the misinformation in the wiki.

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.