Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11967 closed defect (duplicate)

[packages] lang/php5: build failed

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

build log:

API.lo Zend/zend_default_classes.lo Zend/zend_execute.lo main/internal_functions_cli.lo sapi/cgi/cgi_main.lo sapi/cgi/fastcgi.lo -lcrypt -lcrypt -lz -lpcre -lm -ldl -lxml2 -lz -lm -lcrypt -lcrypt  -o sapi/cgi/php-cgi

Build complete.
Don't forget to run 'make test'.

make[4]: Leaving directory `/home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5'
touch /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/.built
mkdir -p /home/openwrt/wndr3700v1/bin/ar71xx/packages /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/ipkg-ar71xx/php5/CONTROL /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/pkginfo
install -d -m0755 /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/ipkg-ar71xx/php5/etc
install -m0644 ./files/php.ini /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/ipkg-ar71xx/php5/etc/
find /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/ipkg-ar71xx/php5 -name 'CVS' -o -name '.svn' -o -name '.#*' -o -name '*~'| xargs -r rm -rf
export CROSS="mips-openwrt-linux-uclibc-"  ; NM="mips-openwrt-linux-uclibc-nm" STRIP="/home/openwrt/wndr3700v1/staging_dir/host/bin/sstrip" STRIP_KMOD="/home/openwrt/wndr3700v1/scripts/strip-kmod.sh" /home/openwrt/wndr3700v1/scripts/rstrip.sh /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/ipkg-ar71xx/php5
( echo "Package: php5"; echo "Version: 5.4.5-3"; DEPENDS=''; for depend in libc libpcre zlib libxml2; do DEPENDS=${DEPENDS:+$DEPENDS, }${depend##+}; done; echo "Depends: $DEPENDS"; echo "Provides: "; echo "Source: feeds/packages/lang/php5"; echo "Section: lang"; echo "Status: unknown ok not-installed"; echo "Essential: no"; echo "Priority: optional"; echo "Maintainer: Michael Heimpold <mhei@heimpold.de>"; echo "Architecture: ar71xx"; echo "Installed-Size: 0"; echo -n "Description: "; . /home/openwrt/wndr3700v1/include/shell.sh; getvar V_Package_php5_description | sed -e 's,^[[:space:]]*, ,g'; ) > /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/ipkg-ar71xx/php5/CONTROL/control
chmod 644 /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/ipkg-ar71xx/php5/CONTROL/control
. /home/openwrt/wndr3700v1/include/shell.sh; (cd /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/ipkg-ar71xx/php5/CONTROL; var2file "V_Package_php5_conffiles" conffiles; )
ipkg-build -c -o 0 -g 0 /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/ipkg-ar71xx/php5 /home/openwrt/wndr3700v1/bin/ar71xx/packages
Packaged contents of /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/ipkg-ar71xx/php5 into /home/openwrt/wndr3700v1/bin/ar71xx/packages/php5_5.4.5-3_ar71xx.ipk
rm -rf /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx/tmp-php5
mkdir -p /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx/stamp /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx/tmp-php5
install -d -m0755 /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx/tmp-php5/etc
install -m0644 ./files/php.ini /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx/tmp-php5/etc/
SHELL= /home/openwrt/wndr3700v1/staging_dir/host/bin/flock /home/openwrt/wndr3700v1/tmp/.root-copy.flock -c 'cp -fpR /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx/tmp-php5/. /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx/'
rm -rf /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx/tmp-php5
touch /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/root-ar71xx/stamp/.php5_installed
make V=ss  -j1 clean-staging
make[4]: Entering directory `/home/openwrt/wndr3700v1/feeds/packages/lang/php5'
rm -f /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.php_installed
make[4]: Leaving directory `/home/openwrt/wndr3700v1/feeds/packages/lang/php5'
rm -rf /home/openwrt/wndr3700v1/tmp/stage-php
mkdir -p /home/openwrt/wndr3700v1/tmp/stage-php/host /home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/packages /home/openwrt/wndr3700v1/staging_dir/host/packages
make -C /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5 install INSTALL_ROOT=/home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/staging
make[4]: Entering directory `/home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5'
Installing shared extensions:     /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/staging/usr/lib/php/extensions/no-debug-non-zts-20100525/
Installing PHP CGI binary:        /home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/staging/usr/bin/
cp: cannot create regular file `/home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/staging/usr/bin/#INST@22610#': No such file or directory
make[4]: *** [install-cgi] Error 1
make[4]: Leaving directory `/home/openwrt/wndr3700v1/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5'
make[3]: *** [/home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.php_installed] Error 2
make[3]: Leaving directory `/home/openwrt/wndr3700v1/feeds/packages/lang/php5'
make[2]: *** [package/feeds/packages/php5/compile] Error 2
make[2]: Leaving directory `/home/openwrt/wndr3700v1'
make[1]: *** [/home/openwrt/wndr3700v1/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/openwrt/wndr3700v1'
make: *** [world] Error 2
openwrt@h2061450:~/wndr3700v1$ 

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by blogic

  • Resolution set to wontfix
  • Status changed from new to closed

comment:2 Changed 6 years ago by anonymous

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Why?

comment:3 Changed 6 years ago by mhei

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #11932. Currently under investigation, but this fix should come from upstream.

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.