Modify

Opened 6 years ago

Last modified 2 years ago

#11960 reopened defect

kmod-fs-ext4 errors leaves root(/)-directory in ready-only mode

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

Following some automated file operations (python) the kmod-fs-ext4 packages spits out the following errors in dmesg:

{{{ [ 276.541811] EXT4-fs error (device sda2): mb_free_blocks:1348: group 129, inode 54001: block 1058073:freeing already freed block (bit 1304)
[ 276.579583] EXT4-fs (sda2): Remounting filesystem read-only
[ 276.596368] EXT4-fs error (device sda2): mb_free_blocks:1348: group 129, inode 54001: block 1058074:freeing already freed block (bit 1305)
[ 276.634007] EXT4-fs error (device sda2): mb_free_blocks:1348: group 129, inode 54001: block 1058075:freeing already freed block (bit 1306)
[ 276.672455] EXT4-fs error (device sda2): ext4_free_inode:289: comm python: bit already cleared for inode 54001

}}}

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by blogic

is this a usb disc ?

comment:2 Changed 5 years ago by blogic

  • Resolution set to too_vague
  • Status changed from new to closed

comment:3 Changed 5 years ago by chris hoogenboom <chris@…>

I just got a similar error -

Oct 18 14:44:59 OpenWrt kern.crit kernel: [ 1050.770000] EXT4-fs error (device s
da1): mb_free_blocks:1348: group 1, inode 1201: block 35085:freeing already free
d block (bit 2317)
Oct 18 14:44:59 OpenWrt kern.crit kernel: [ 1050.900000] EXT4-fs error (device s
da1): mb_free_blocks:1348: group 1, inode 1201: block 35086:freeing already free
d block (bit 2318)
Oct 18 14:44:59 OpenWrt kern.crit kernel: [ 1051.040000] EXT4-fs error (device s
da1): mb_free_blocks:1348: group 1, inode 1201: block 35087:freeing already free
d block (bit 2319)

OpenWrt Attitude Adjustment 12.09-beta2 / LuCI 0.11 Branch (0.11+svn9364)
TP-Link TL-MR3020 v1

using extroot running from a microSD hosted in a Novatel U760 3G CDMA modem.

In addition, the system periodically enters a state where it apears the root fs is gone/missing/unmounted. Assuming I am logged in via ssh I still have a working command prompt but every command I enter I get a "command not found" error. I suspect the two are related.

comment:4 Changed 5 years ago by chris hoogenboom <chris@…>

  • Resolution too_vague deleted
  • Status changed from closed to reopened

comment:5 follow-up: Changed 5 years ago by DoSpamMe@…

I got similar error too.

  • I'm using a mmc usb card reader.
  • AA 12.09 RC1
  • TL-WR842ND router.
  • Tried two different sdhc cards (both new) from different vendors.
  • Tried ext4 both with and without has_journal. Tried ext2 as well.
  • I always had two partitions swap and ext.

I'm using overlay pivot. It seems to work for first couple of minutes. But after installing 2-3 packages IO errors start showing up and device is remount RO.

[   41.600000] device eth0 entered promiscuous mode
[   44.250000] eth1: link up (100Mbps/Full duplex)
[  252.800000] usb 1-1.1: reset high-speed USB device number 3 using ehci-platform
[  254.200000] sd 0:0:0:0: [sda] Media Changed
[  254.200000] sd 0:0:0:0: [sda]  Result: hostbyte=0x00 driverbyte=0x08
[  254.200000] sd 0:0:0:0: [sda]  Sense Key : 0x6 [current]
[  254.200000] Info fld=0x0
[  254.210000] sd 0:0:0:0: [sda]  ASC=0x28 ASCQ=0x0
[  254.210000] sd 0:0:0:0: [sda] CDB: cdb[0]=0x2a: 2a 00 00 00 0f e0 00 00 08 00
[  254.210000] end_request: I/O error, dev sda, sector 4064
[  254.210000] Buffer I/O error on device sda1, logical block 252
[  254.220000] lost page write due to I/O error on sda1
[  261.310000] EXT4-fs error (device sda1): ext4_read_inode_bitmap:161: comm opkg: Cannot read inode bitmap - block_group = 0, inode_bitmap = 252
[  261.320000] EXT4-fs error (device sda1) in ext4_new_inode:941: IO failure
[  261.330000] EXT4-fs error (device sda1): ext4_read_inode_bitmap:161: comm opkg: Cannot read inode bitmap - block_group = 0, inode_bitmap = 252
[  261.350000] EXT4-fs error (device sda1) in ext4_new_inode:941: IO failure
[  261.350000] EXT4-fs (sda1): previous I/O error to superblock detected
[  261.370000] EXT4-fs error (device sda1): ext4_read_inode_bitmap:161: comm opkg: Cannot read inode bitmap - block_group = 0, inode_bitmap = 252
[  261.380000] EXT4-fs error (device sda1) in ext4_new_inode:941: IO failure
[  261.390000] EXT4-fs (sda1): previous I/O error to superblock detected
[  261.400000] EXT4-fs error (device sda1): ext4_read_inode_bitmap:161: comm opkg: Cannot read inode bitmap - block_group = 0, inode_bitmap = 252
[  261.410000] EXT4-fs error (device sda1) in ext4_new_inode:941: IO failure
[  261.420000] EXT4-fs (sda1): previous I/O error to superblock detected
[  261.430000] EXT4-fs error (device sda1): ext4_read_inode_bitmap:161: comm opkg: Cannot read inode bitmap - block_group = 0, inode_bitmap = 252
[  261.440000] EXT4-fs error (device sda1) in ext4_new_inode:941: IO failure
[  261.450000] EXT4-fs (sda1): previous I/O error to superblock detected
[  261.590000] Buffer I/O error on device sda1, logical block 34346
[  261.590000] EXT4-fs warning (device sda1): ext4_end_bio:250: I/O error writing to inode 144 (offset 0 size 4096 starting block 34603)
[  261.610000] Buffer I/O error on device sda1, logical block 34346
[  261.610000] Buffer I/O error on device sda1, logical block 34347
[  261.610000] EXT4-fs warning (device sda1): ext4_end_bio:250: I/O error writing to inode 144 (offset 0 size 8192 starting block 34604)
[  261.630000] Buffer I/O error on device sda1, logical block 34347
[  261.630000] Buffer I/O error on device sda1, logical block 34348
[  261.630000] EXT4-fs warning (device sda1): ext4_end_bio:250: I/O error writing to inode 144 (offset 4096 size 8192 starting block 34605)
[  261.660000] Buffer I/O error on device sda1, logical block 34348
[  261.660000] EXT4-fs warning (device sda1): ext4_end_bio:250: I/O error writing to inode 144 (offset 8192 size 4096 starting block 34605)
[  261.680000] Buffer I/O error on device sda1, logical block 34348
[  261.680000] Buffer I/O error on device sda1, logical block 34349

Following the discussion here I wanted to remove the kmod-fs-ext4 and use kmod-fs-ext3 instead but unfortunately it seems the ext3 package has been decommissioned from the AA.

comment:6 Changed 5 years ago by DoSpamMe@…

Seems to me like some incompatibility among my mmc card reader (which is an usb hub also), tp-link router and some software. Since I put another usb-hub in between the card reader and the router and now everything is working ok. It has been running with no IO error last couple of weeks.

Maybe this ticket is a duplicate of the #6779..

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:8 in reply to: ↑ 5 Changed 2 years ago by Barrack Hussien Bombama

looks like not enough power was supplied for a moment.. same crap with CC 15.05, even using usb3 port with normal 5V 2.5" hdd, there should be solution just to remount root automatically in such cases.. cheers!

[22301.645296] EXT4-fs error (device sda3): ext4_read_inode_bitmap:185: comm nmbd: Cannot read inode bitmap - block_group = 67, inode_bitmap = 2195457
[22306.988552] EXT4-fs error: 78 callbacks suppressed
[22306.993384] EXT4-fs error (device sda3): ext4_get_inode_loc:3818: inode #476228: block 1900556: comm named: unable to read itable block
[22307.005787] EXT4-fs error (device sda3) in ext4_reserve_inode_write:4784: IO failure
[22307.033990] EXT4-fs error (device sda3): ext4_wait_block_bitmap:494: comm named: Cannot read block bitmap - block_group = 61, block_bitmap = 1998848
[22307.047415] EXT4-fs error (device sda3):
ext4_get_inode_loc:3818: inode #476228: block 1900556: comm named: unable to read itable block
[22307.059822] EXT4-fs error (device sda3) in ext4_reserve_inode_write:4784: IO failure
[22312.255207] EXT4-fs error: 126 callbacks suppressed
[22312.260111] EXT4-fs error (device sda3): ext4_read_inode_bitmap:185: comm nmbd: Cannot read inode bitmap - block_group = 58, inode_bitmap = 1900545
[22312.273398] EXT4-fs error (device sda3): ext4_read_inode_bitmap:185: comm nmbd: Cannot read inode bitmap - block_group = 59, inode_bitmap = 1933313

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.