Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11944 closed defect (duplicate)

CUPS USB timeout: 'Unable to write 8192 bytes to printer!'

Reported by: pieter.agten@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: cups usb timeout Cc:

Description

When printing to slow USB printers (such as many of the Canon PIXMA MP series), CUPS very often produces a timeout. This usually halts the printer mid-print and generates the following error message in the web interface and the logs: 'Unable to write 8192 bytes to printer!'.

The fix for this is to increase the timeout value when doing usb writes. This has been fixed in cups-1.4.5 but I have also included a patch for cups-1.4.4 (which is the version currently included in OpenWrt). This patch increases the timeout from 45 seconds to 5 minutes, which has fixed the problem for me.

A quick Google for the above error message will show that a lot of people seem to be affected by this bug (or at least were at some time in the past).

Note: for me this problem occurred using a Canon PIXMA MP500 printer.

PS: I have no idea on what milestone this should be...

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by pieter.agten@…

This is a duplicate of #11945. Trac kept giving me database errors while submitting this bug, so I guess it registered it twice. See bug #11945 for the patch!

comment:2 Changed 6 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.