Modify

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#11942 closed defect (duplicate)

TP-LINK TL-WR1043ND - sta and ap doesn't work same time.

Reported by: EXcomZkko <excom_zkko@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

I'm using my router for repeater function. upgraded from r32775 to latest trunk and sta+ap no longer works. when I add second vif (one of sta or ap), both connections are fails. then downgraded to r32775, and everything is fine again.

my config;

config 'interface' 'loopback'
	option 'ifname' 'lo'
	option 'proto' 'static'
	option 'ipaddr' '127.0.0.1'
	option 'netmask' '255.0.0.0'

config 'interface' 'lan'
	option 'type' 'bridge'
	option 'proto' 'static'
	option 'ipaddr' '192.168.1.1'
	option 'netmask' '255.255.255.0'
	option 'gateway' '192.168.1.1'
	option 'dns' '192.168.1.1'
	option '_orig_ifname' 'eth0.1 wlan0'
	option '_orig_bridge' 'true'
	option 'ifname' 'eth0'

config 'interface' 'wan'
	option 'proto' 'dhcp'
	option '_orig_ifname' 'eth0.2'
	option '_orig_bridge' 'false'

config 'switch'
	option 'name' 'rtl8366rb'
	option 'reset' '1'
	option 'enable_vlan' '1'

config 'switch_vlan'
	option 'device' 'rtl8366rb'
	option 'vlan' '1'
	option 'ports' '1 2 3 4 5t'

config 'switch_vlan'
	option 'device' 'rtl8366rb'
	option 'vlan' '2'
	option 'ports' '0 5t'

and

config 'wifi-device' 'radio0'
	option 'type' 'mac80211'
	option 'macaddr' 'f8:d1:xx:xx:xx:xx'
	option 'hwmode' '11ng'
	option 'htmode' 'HT20'
	list 'ht_capab' 'SHORT-GI-40'
	list 'ht_capab' 'DSSS_CCK-40'
	option 'channel' '6'
	option 'txpower' '24'

config 'wifi-iface'
	option 'device' 'radio0'
	option 'mode' 'ap'
	option 'ssid' 'OpenWrt'
	option 'encryption' 'psk2+ccmp'
	option 'key' 'xxxx'
	option 'network' 'lan'

config 'wifi-iface'
	option 'device' 'radio0'
	option 'ssid' 'TP-LINK'
	option 'mode' 'sta'
	option 'encryption' 'psk2+ccmp'
	option 'key' 'xxxx'
	option 'network' 'wan'

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by eleon216

duplicate of 11914 /ticket/11914.html
workaround can be found there

comment:2 Changed 6 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.