Modify

Opened 6 years ago

Closed 3 years ago

#11932 closed defect (fixed)

php-5.4.5 does not build

Reported by: anonymous Owned by: mhei
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

hello,
i'm currently on:

URL: svn://svn.openwrt.org/openwrt/trunk
Repository Root: svn://svn.openwrt.org/openwrt
Repository UUID: 3c298f89-4303-0410-b956-a3cf2f4a3e73
Revision: 32903
Node Kind: directory
Schedule: normal
Last Changed Author: blogic
Last Changed Rev: 32902
Last Changed Date: 2012-07-28 23:06:59 +0200 (Sat, 28 Jul 2012)

now, php-5.4.5 does not build here, it fails with:

make[4]: Entering directory `/home/flo/openwrt/trunk/feeds/packages/lang/php5'
rm -f /home/flo/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.php_installed
make[4]: Leaving directory `/home/flo/openwrt/trunk/feeds/packages/lang/php5'
rm -rf /home/flo/openwrt/trunk/tmp/stage-php
mkdir -p /home/flo/openwrt/trunk/tmp/stage-php/host /home/flo/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/packages /home/flo/openwrt/trunk/staging_dir/host/packages
make -C /home/flo/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5 install INSTALL_ROOT=/home/flo/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/staging
make[4]: Entering directory `/home/flo/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5'
Installing shared extensions:     /home/flo/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/staging/usr/lib/php/extensions/no-debug-non-zts-20100525/
Installing PHP CGI binary:        /home/flo/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/staging/usr/bin/
cp: cannot create regular file `/home/flo/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5/staging/usr/bin/#INST@4396#': No such file or directory
make[4]: *** [install-cgi] Error 1
make[4]: Leaving directory `/home/flo/openwrt/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/php-5.4.5'
make[3]: *** [/home/flo/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.php_installed] Error 2
make[3]: Leaving directory `/home/flo/openwrt/trunk/feeds/packages/lang/php5'
make[2]: *** [package/feeds/packages/php5/compile] Error 2
make[2]: Leaving directory `/home/flo/openwrt/trunk'
make[1]: *** [/home/flo/openwrt/trunk/staging_dir/target-mips_r2_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/flo/openwrt/trunk'
make: *** [world] Error 2

i already tried a completely new checkout - no luck...
Any hints?
Thanks a lot...

Attachments (0)

Change History (7)

comment:1 Changed 6 years ago by anonymous

oh and btw:
i'm building for a Netgear WNDR3800 Device.
the PHP configuration is:

CONFIG_PACKAGE_php5=y
CONFIG_PACKAGE_php5-cgi=y
CONFIG_PACKAGE_php5-fastcgi=y
CONFIG_PACKAGE_php5-mod-gd=y
CONFIG_PACKAGE_php5-mod-hash=y
CONFIG_PACKAGE_php5-mod-json=y
CONFIG_PACKAGE_php5-mod-mbstring=y
CONFIG_PACKAGE_php5-mod-mcrypt=y
CONFIG_PACKAGE_php5-mod-mysqli=y
CONFIG_PACKAGE_php5-mod-openssl=y
CONFIG_PACKAGE_php5-mod-session=y
CONFIG_PACKAGE_php5-mod-zip=y

comment:2 Changed 6 years ago by mhei

Hm, seems to be this one: https://bugs.php.net/bug.php?id=61345
As a workaround, I'm thinking about enabling the cli unconditionally. This should fix the cgi build too.

comment:3 Changed 6 years ago by mhei

  • Owner changed from developers to mhei
  • Status changed from new to assigned

comment:4 Changed 6 years ago by olistudent <oliver@…>

Why not create the bindir like in cli install?

  • php-5.4.5/sapi/cgi/Makefile.frag

    old new  
    55 
    66install-cgi: $(SAPI_CGI_PATH) 
    77       @echo "Installing PHP CGI binary:        $(INSTALL_ROOT)$(bindir)/" 
     8       @$(mkinstalldirs) $(INSTALL_ROOT)$(bindir) 
    89       @$(INSTALL) -m 0755 $(SAPI_CGI_PATH) $(INSTALL_ROOT)$(bindir)/$(program_prefix)php-cgi$(program_suffix)$(EXEEXT) 

Wondering why this should have worked for 5.3.X according to the last entry of the referenced ticket?

comment:5 Changed 5 years ago by Spencer Thomason <spencer.thomason@…>

Has anyone had any luck with this? Using CLI isn't a workaround that works for me - so if there is another way I can do this, that would be great!

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:7 Changed 3 years ago by mhei

  • Resolution set to fixed
  • Status changed from assigned to closed

This problem was fixed long time ago: both sapis cli and cgi are built unconditionally, so this issue should not happen anymore.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.