Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#11922 closed defect (fixed)

beaconing stops in mesh mode

Reported by: marco.porsch@… Owned by: nbd
Priority: normal Milestone: Barrier Breaker 14.07
Component: kernel Version: Trunk
Keywords: Cc:

Description

This happens very often after peering activity.

Example scenario:
3 mesh nodes up and peering established.
Disable mesh node 1 (ifconfig mesh0 down)

Expected behaviour:
node 1 stops beaconing, some peering close transmissions, but the other two continue beaconing

Actual outcome:
node 1 stops beaconing, some peering close transmissions, *all* nodes stop beaconing, some 60s later the other two continue

Hardware used: WNDR3700 + WNDR3800 (ath9k)

OpenWrt trunk r32885 (compat-wireless-2012-07-16)

Attachments (2)

mesh_beacon_silence.pcap (4.6 KB) - added by marco.porsch@… 6 years ago.
pcap of example scenario
0001-mac80211-fix-unnecessary-beacon-update-after-peering.patch (8.4 KB) - added by marco.porsch@… 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by marco.porsch@…

pcap of example scenario

comment:1 Changed 6 years ago by marco.porsch@…

I logged all ath9k debug outputs at the nodes that stop beaconing and made some markups.

When shutting down the peers interface:
http://pastebin.com/XPGztw8m

When the node re-starts beaconing after some time has passed.
I should mention here, that this specific time is the same for the 2 remaining mesh routers, as these restart beaconing at approximately the same time. But the silence interval varies in length (once measured 34.8s the other time 65.5s).
Maybe when one node starts again it kicks the others on somehow?
http://pastebin.com/r9WC8w30

comment:2 Changed 5 years ago by nbd

  • Owner changed from developers to nbd
  • Status changed from new to accepted

comment:3 Changed 5 years ago by marco.porsch@…

The problem is triggered by the call to ieee80211_bss_info_change_notify in mesh_plink.c : mesh_rx_plink_frame.

Although the real problem seems to come from ath9k, the attached patch successfully workarounds this for me.

comment:4 Changed 5 years ago by nbd

does this still occur with the latest version?

comment:5 Changed 5 years ago by marco.porsch@…

I have not seen the bug in a while, so I tend to say it has been fixed.

comment:6 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from accepted to closed

great, thanks.

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.