Modify

Opened 6 years ago

Closed 5 years ago

Last modified 3 years ago

#11843 closed enhancement (duplicate)

Please include traceroute6 inside OpenWRT as a default

Reported by: alphasparc@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

ping6 is already a default application in OpenWRT, please make traceroute6 as a default as well.
ping6 works inside LuCI Diagnostic Tool, please include traceroute6 as well.

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by alphasparc@…

Hi, I want to update you guys on the issue.
I build an image for trunk and added traceroute6 from busybox.
The issue isn't that traceroute cannot hit ipv6 address, it is because the packets cannot be sent properly.
The problem isn't OpenWRT, it is most likely the traceroute binary from busybox.
I have tested adding allow any ipv6 input on iptables result: no go
The packets fail with

1traceroute6: sendto: Operation not permitted

It only worked after I stopped iptables with /etc/init.d/firewall stop

I am not sure if I should file a bug with busybox upstream or not any advice?

comment:2 Changed 6 years ago by alphasparc@…

I forgot to mention from issuing ping6 ipv6.google.com works fine from connected clients but not on the router itself.

comment:3 Changed 5 years ago by jow

  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.