Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#11841 closed defect (duplicate)

Rate marked as an HT rate but passed status->rate_idx is not an MCS index [0-76]: 79 (0x4f)

Reported by: Christophe <christophe@…> Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hey, I'm seeing those once in a while. TL-WR1043ND, r32656.

WARNING: at /opt/openwrt-trunk/build_dir/linux-ar71xx_generic/compat-wireless-2012-07-06/net/mac80211/rx.c:3070 ieee80211_rx+0x138/0x7b0 [mac80211]()
Rate marked as an HT rate but passed status->rate_idx is not an MCS index [0-76]: 79 (0x4f)
Modules linked in: ath79_wdt [...]
Call Trace:
[<80268ec4>] dump_stack+0x8/0x34
[<80071c2c>] warn_slowpath_common+0x78/0xa4
[<80071ce0>] warn_slowpath_fmt+0x2c/0x38
[<814587fc>] ieee80211_rx+0x138/0x7b0 [mac80211]
[<815679c4>] ath_rx_tasklet+0xf8c/0x10b8 [ath9k]
[<815658f4>] ath9k_tasklet+0x114/0x170 [ath9k]
[<80076d30>] tasklet_action+0x7c/0xd4
[<80077258>] __do_softirq+0xa0/0x154
[<80077468>] do_softirq+0x48/0x68
[<8007769c>] irq_exit+0x4c/0x78
[<80062f6c>] ret_from_irq+0x0/0x4
[<80063160>] r4k_wait+0x20/0x40
[<80064c34>] cpu_idle+0x30/0x60
[<802fa8b4>] start_kernel+0x368/0x388

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by Clayman

Got the same message here. TL-WR941NDv3, trunk r33290.

[629648.540000] ------------[ cut here ]------------
[629648.550000] WARNING: at /home/clayman/OpenWRT/trunk/build_dir/linux-ar71xx_generic/compat-wireless-2012-07-16/net/mac80211/rx.c:3039 0x80c59838()
[629648.560000] Rate marked as an HT rate but passed status->rate_idx is not an MCS index [0-76]: 77 (0x4d)
[629648.570000] Modules linked in: ath79_wdt ledtrig_netdev nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat pppoe xt_conntrack xt_CT xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc ath9k(O) ath9k_common(O) ath9k_hw(O) ath(O) mac80211(O) crc_ccitt cfg80211(O) compat(O) arc4 aes_generic crypto_algapi ledtrig_timer ledtrig_default_on leds_gpio gpio_button_hotplug(O)
[629648.620000] Call Trace:[<80263f9c>] 0x80263f9c
[629648.630000] [<80263f9c>] 0x80263f9c
[629648.630000] [<800718ac>] 0x800718ac
[629648.630000] [<80c59838>] 0x80c59838
[629648.640000] [<80071960>] 0x80071960
[629648.640000] [<80c59838>] 0x80c59838
[629648.640000] [<801d85d0>] 0x801d85d0
[629648.650000] [<80ce6d90>] 0x80ce6d90
[629648.650000] [<80257948>] 0x80257948
[629648.650000] [<80160ac4>] 0x80160ac4
[629648.660000] [<8006b600>] 0x8006b600
[629648.660000] [<80ce4f08>] 0x80ce4f08
[629648.670000] [<80076990>] 0x80076990
[629648.670000] [<80076eb4>] 0x80076eb4
[629648.670000] [<802f0000>] 0x802f0000
[629648.680000] [<802f0000>] 0x802f0000
[629648.680000] [<800770c0>] 0x800770c0
[629648.680000] [<800a8380>] 0x800a8380
[629648.690000] [<800772f4>] 0x800772f4
[629648.690000] [<80062f8c>] 0x80062f8c
[629648.690000] [<80063160>] 0x80063160
[629648.700000] [<802f0000>] 0x802f0000
[629648.700000] [<800950b0>] 0x800950b0
[629648.700000] [<800649c8>] 0x800649c8
[629648.710000] [<80063180>] 0x80063180
[629648.710000] [<802cc8b0>] 0x802cc8b0
[629648.720000] [<802cc0dc>] 0x802cc0dc
[629648.720000] 
[629648.720000] ---[ end trace b6f0b6440825f7d3 ]---

comment:2 Changed 5 years ago by nbd

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #6411

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.