Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#11834 closed defect (worksforme)

DECT phone, ath9k DMA failure

Reported by: anonymous Owned by: developers
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi,

i was just playing an online game while a call came in. instantly i had a wifi disconnect and those RX DMA failures in syslog.

maybe this helps finding this issue ....

l 9 18:08:23 OpenWrt daemon.info hostapd: wlan0: STA 00:1f:1f:bb:bd:64 WPA: group key handshake completed (RSN)
Jul 9 18:08:23 OpenWrt daemon.info hostapd: wlan0: STA 7c:dd:90:15:9a:d4 WPA: group key handshake completed (RSN)
Jul 9 18:08:24 OpenWrt daemon.info hostapd: wlan0: STA 78:d6:f0:0a:55:f9 WPA: group key handshake completed (RSN)
Jul 9 18:11:03 OpenWrt kern.err kernel: [94133.400000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Jul 9 18:11:03 OpenWrt kern.err kernel: [94133.630000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x00026040
Jul 9 18:11:03 OpenWrt kern.err kernel: [94133.640000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
Jul 9 18:11:03 OpenWrt kern.err kernel: [94133.660000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Jul 9 18:11:03 OpenWrt daemon.notice netifd: wan (815): Sending renew...
Jul 9 18:11:03 OpenWrt daemon.notice netifd: wan (815): udhcpc: write: Operation not permitted
Jul 9 18:11:03 OpenWrt kern.err kernel: [94133.890000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x00026020
Jul 9 18:11:03 OpenWrt kern.err kernel: [94133.900000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
Jul 9 18:11:03 OpenWrt kern.err kernel: [94133.920000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Jul 9 18:11:03 OpenWrt kern.err kernel: [94134.150000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x00026020
Jul 9 18:11:03 OpenWrt kern.err kernel: [94134.160000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
Jul 9 18:11:03 OpenWrt kern.err kernel: [94134.180000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Jul 9 18:11:04 OpenWrt kern.err kernel: [94134.420000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x00026020
Jul 9 18:11:04 OpenWrt kern.err kernel: [94134.430000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
Jul 9 18:11:04 OpenWrt kern.err kernel: [94134.450000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Jul 9 18:11:04 OpenWrt kern.err kernel: [94134.680000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x00026020
Jul 9 18:11:04 OpenWrt kern.err kernel: [94134.690000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
Jul 9 18:11:04 OpenWrt kern.err kernel: [94134.710000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Jul 9 18:11:04 OpenWrt kern.err kernel: [94134.940000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x00026020
Jul 9 18:11:04 OpenWrt kern.err kernel: [94134.950000] ath: phy0: Could not stop RX, we could be confusing the DMA engine when we start RX up
Jul 9 18:11:04 OpenWrt kern.err kernel: [94134.970000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Jul 9 18:11:04 OpenWrt kern.err kernel: [94135.200000] ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x42000020 DMADBG_7=0x00026020
Jul 9 18:11:04 OpenWrt kern.err kernel: [94135.210000] ath: phy0: Could not stop RX, we could

Attachments (0)

Change History (20)

comment:1 Changed 6 years ago by anonymous

wzr hp g300nh

comment:2 Changed 6 years ago by nbd

please try latest trunk

comment:3 Changed 6 years ago by anonymous

so far seems ok but i need more time to test stability.

please be aware that latest trunk of today cut performance in ath9k by 50% ! it happened r32656

comment:4 Changed 6 years ago by nbd

are you sure it is that patch? did you try removing package/mac80211/patches/566-ath9k_fix_initval_array.patch from current trunk to verify?

comment:5 Changed 6 years ago by nbd

oh, never mind, i found the cause of the throughput regression. fixed in r32668

comment:6 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

marking as fixed. reopen if the problem shows up again.

comment:7 Changed 6 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

i love poetry to avoid askiment spam filter

........... -> DECT still crashes r32669. except that its quite stable. performance is acceptable. Each time i get a DECT phone call i get DMA failures

OpenWRT ticket is reopened

comment:8 Changed 6 years ago by jow

  • Priority changed from normal to response-needed

How can it be stable and crashing at the same time? Fixing the ticket does not mean that the messages will be gone, just that the wifi will recover. So clarify, is it stable or is it crashing?

comment:9 Changed 6 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

should be fixed in r32709

comment:10 Changed 6 years ago by anonymous

I meant That except the dect phone thing ath9k works quite good. Ill test 32709

comment:11 Changed 6 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

i love poetry to avoid askiment spam filter

release r32764 is still disturbed by DECT. without the phone its pretty stable

Jul 22 22:01:27 OpenWrt kern.err kernel: [ 85.370000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Jul 22 22:01:27 OpenWrt kern.err kernel: [ 85.610000] ath: phy0: Failed to stop TX DMA, queues=0x004!

comment:12 Changed 6 years ago by anonymous

ath9k on wzr hp g300nh has problems with noise from DECT or other wlan channels. a longer duration of usage of the latest trunks always shows wifi disconnects / drops for some seconds when other signals are disturbing

comment:13 Changed 5 years ago by anonymous

latest trunk seems to fix the problems , give me 1-2 weeks more, ill report it if this can be closed

comment:14 Changed 5 years ago by anonymous

found that in 33057:

Aug 9 09:11:39 OpenWrt kern.err kernel: [44079.330000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Aug 9 09:11:40 OpenWrt kern.err kernel: [44080.280000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Aug 9 09:11:46 OpenWrt kern.err kernel: [44086.310000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Aug 9 09:11:47 OpenWrt kern.err kernel: [44087.250000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Aug 9 09:11:48 OpenWrt kern.err kernel: [44088.420000] ath: phy0: Failed to stop TX DMA, queues=0x004!
Aug 9 09:11:57 OpenWrt daemon.info hostapd: wlan0: STA 7c:dd:90:15:9a:d4 IEEE 802.11: authenticated

comment:15 Changed 5 years ago by anonymous

not completely fixed in trunk 33287 , but by far better. wifi tx dma gets more rare and the wifi can revive itself without restart....

will continue to report

comment:16 Changed 5 years ago by anonymous

latest trunk with GCC patch gets even more stable , but i still get tx dma problems.

r33338

comment:17 Changed 5 years ago by anonymous

r33401 , still DMA problems, but rare

comment:18 Changed 5 years ago by nbd

please try latest trunk or AA

comment:19 Changed 5 years ago by nbd

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:20 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.