Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#11824 closed defect (fixed)

Enabling ipv6 on pppoe-wan interface breaks resolv.conf.auto / dnsmasq

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

As title says, when enabling ipv6 on pppoe wan interface, resolve.conf.auto will remain empty and dnsmasq will not be able to offer dns service to dhcp clients.

Tried with clean flash and no configuration except enabling wan interface.

Very easy to test, without "option ipv6 1" everything works fine. With "option ipv6 1", dns fails.

It has been this way for quite some time. I think it started with r31830 but can't say for sure.

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by anonymous

when/how is /tmp/resolv.conf.auto created for pppoe-wan? from netifd?

i've noticed that /tmp/resolv.conf.ppp actually does contain the correct nameservers.. but since dnsmasq uses resolv.conf.auto it doesn't really matter.

probably would be easy to change init scripts to make dirty fix for this.. but the real problem is something else.

comment:2 Changed 5 years ago by anonymous

Seems duplicate of 11501.

comment:3 Changed 5 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r34500, will be backported to AA soon

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.