Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#11791 closed defect (fixed)

minidlna broken

Reported by: anonymous Owned by: jow
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

make[4]: Entering directory `/home/user/openwrt/build_dir/linux-cns21xx/minidlna-1.0.24'
Linking minidlna
minidlna.o: In function `main':
minidlna.c:(.text.startup+0x60): undefined reference to `libintl_bindtextdomain'
minidlna.c:(.text.startup+0x88): undefined reference to `libintl_textdomain'
scanner.o: In function `insert_file':
scanner.c:(.text+0x9a8): undefined reference to `libintl_gettext'
scanner.c:(.text+0xad0): undefined reference to `libintl_gettext'
scanner.c:(.text+0xec0): undefined reference to `libintl_gettext'
scanner.c:(.text+0xf5c): undefined reference to `libintl_gettext'
scanner.c:(.text+0xfb0): undefined reference to `libintl_gettext'
scanner.o:scanner.c:(.text+0x1020): more undefined references to `libintl_gettext' follow
collect2: error: ld returned 1 exit status
make[4]: *** [minidlna] Error 1
make[4]: Leaving directory `/home/user/openwrt/build_dir/linux-cns21xx/minidlna-1.0.24'
make[3]: *** [/home/user/openwrt/build_dir/linux-cns21xx/minidlna-1.0.24/.built] Error 2
make[3]: Leaving directory `/home/user/openwrt/feeds/packages/multimedia/minidlna'
make[2]: *** [package/feeds/packages/minidlna/compile] Error 2
make[2]: Leaving directory `/home/yaroslaw/openwrt'
make[1]: *** [/home/user/openwrt/staging_dir/target-arm_v4_uClibc-0.9.33.2_eabi/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/user/openwrt'
make: *** [world] Ошибка 2

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by anonymous

Target: cns21xx
Toolchain: gcc4.7-linaro

comment:2 Changed 6 years ago by anonymous

Can anyone confirm that or it's just for me?

comment:3 Changed 6 years ago by jow

Well the buildbots do not agree, it might be related to your host system.
Please attach the config.log here.

comment:4 Changed 6 years ago by thess

I too have had this problem. I think it is related to CONFIG_BUILD_NLS=y, but I have not verified it. If you edit the package Makefile and change the ICONV_LIBS line to:

ICONV_LIBS="-liconv -lintl" \

You will be good to go. Like I said, I haven't tried building minidlna without CONFIG_BUILD_NLS set. I think the buildbot uses the 'stubs'.

comment:5 Changed 6 years ago by zentavr@…

I've added ICONV_LIBS="-licinv -lintl" to Makefile in /home/zentavr/openwrt/sources/trunk/build_dir/linux-ar71xx_generic/minidlna-1.0.24 and the same error happened.

CONFIG_BUILD_NLS=y exists into my /home/zentavr/openwrt/sources/trunk/.config file. So, should I drop it from there?

comment:6 Changed 6 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

The correct solution would be:

ICONV_LIBS="-liconv $(if $(INTL_FULL),-lintl)" \

comment:7 Changed 5 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed with r33125

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.