Modify

Opened 6 years ago

Closed 5 years ago

Last modified 4 years ago

#11780 closed defect (fixed)

Multiwan is broken for DHCP and PPPoE interfaces since /etc/ppp/ip-up was removed

Reported by: Carlos Moran <cmoran92@…> Owned by: jow
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

It expects to obtain IP address and gateway information using uci_get_state, using /etc/config/network and /var/state/network as the sources, but since /etc/ppp/ip-up was removed, that information is missing from /var/state/network, so multiwan thinks all PPPoE and DHCP interfaces have failed and doesn't create any default route.

In response to #11772, jow said "It should be changed to use /lib/functions/network.sh to find the interface details."

Attachments (2)

multiwan-use-network-functions.patch (2.0 KB) - added by jow 6 years ago.
use network functions
multiwan-use-network-functions.2.patch (2.1 KB) - added by jow 6 years ago.
fixed patch

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by jow

use network functions

comment:1 Changed 6 years ago by jow

  • Priority changed from normal to response-needed

Please try the attached patch, note that it also depends on r32531

comment:2 Changed 6 years ago by jow

  • Owner changed from developers to jow
  • Status changed from new to accepted

Changed 6 years ago by jow

fixed patch

comment:3 Changed 6 years ago by jow

I forgot to actually include network.sh in the previous patch, use the revised version

comment:4 Changed 6 years ago by tero.janka@…

I tried the revised patch, but unfortunately it didn't fix it for me. Multiwan reports:

multiwan: wan has failed and is currently offline.
multiwan: wan2 has failed and is currently offline.

wan is a wired ethernet dhcp interface and wan2 is a dhcp usb 3G dongle interface. I tried with and without 'option defaultroute 0' and 'option peerdns 0' options in /etc/config/network for both interfaces. dns servers are manually configured in /etc/config/multiwan.

comment:5 Changed 6 years ago by tero.janka@…

I ran "/etc/init.d/multiwan restart" again today, and suddenly it started working, weird. I didn't even change the config. It even works after reboot. Please ignore my previous comment about the revised patch not working. For now it is working perfectly. Thanks jow!

comment:6 Changed 5 years ago by jow

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed with r33052

comment:7 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.