Modify

Opened 6 years ago

Closed 3 years ago

#11778 closed defect (no_response)

ZNC 0.206-1 using 100% CPU

Reported by: rebel@… Owned by: jogo
Priority: response-needed Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: ZNC IRC r29045 CPU Cc:

Description

Hello, first I would like to thank you guys for this great router firmware.
I recently updated ZNC from 0.202-1 to 0.206-1, along with some modules, and it's using a large amount of the cpu (if not all), which is creating about a 5-10 second lag on IRC.
I'm running Attitude Adjustment r29045 on a Buffalo WZR-HP-G300NH.

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by jogo

  • Owner changed from developers to jogo
  • Priority changed from low to response-needed
  • Status changed from new to assigned

There was a uClibc update between ZNC 0.202 and 0.206, likely causing brakage when installing packages compiled for the "wrong" version. Please try again after updating to a current snapshot image.

comment:2 Changed 5 years ago by nbd

  • Resolution set to no_response
  • Status changed from assigned to closed

comment:3 Changed 4 years ago by anonymous

  • Resolution no_response deleted
  • Status changed from closed to reopened

This is still happening, but I'm not sure it's the same bug. In my case, znc uses 100% CPU and almost hangs for one or two minutes after login and joining channels (and by "after" I mean literally: joining channels is naturally laggy, but znc becomes unresponsive after that). I'm connecting to freenode through SSL, and joining a few crowded channels.

My system is a TP-LINK TL-WR1043ND:
# opkg list-installed | grep znc
znc - 0.206-2
# cat /etc/openwrt_release
DISTRIB_ID="OpenWrt"
DISTRIB_RELEASE="12.09"
DISTRIB_REVISION="r36088"
DISTRIB_CODENAME="attitude_adjustment"
DISTRIB_TARGET="ar71xx/generic"
DISTRIB_DESCRIPTION="OpenWrt Attitude Adjustment 12.09"

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

comment:5 Changed 3 years ago by anonymous

Well, this just got worse in BB-rc2... znc takes >2 minutes to become responsible, say, opening freenode's ##linux channel (~1500 users). The more crowded the channel (s), the slower it becomes.
I'm wondering why is ZNC parsing the userlist from /WHO, at all, even when the command is sent directly to the remote server.

comment:6 Changed 3 years ago by jogo

I just pushed a commit switching to libstdcpp, which should fix the hang on join. Can you confirm the issue is gone on trunk?

comment:7 Changed 3 years ago by nbd

  • Resolution set to no_response
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.