Modify

Opened 6 years ago

Last modified 4 years ago

#11748 new defect

cannot compile appweb

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version: Trunk
Keywords: Cc:

Description

hi,
i have already submitted this thicked, but it is no longer there. So i am submitting it again.
I have tryed to patch Makefile.top but it didn't worked.
A suggestion was to patch Makefile.in, but i don't know where to find it. Can somebody help me.
attached is the patch, which i used for the Makefile.top

make[2]: Entering directory `/media/linDATA/OpenWRT_dev/trunk/feeds/packages/net/appweb'
make -C /media/linDATA/OpenWRT_dev/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/appweb-3.2.2-1 AR=mips-openwrt-linux-uclibc-ar AS="mips-openwrt-linux-uclibc-gcc -c -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float" LD=mips-openwrt-linux-uclibc-ld NM=mips-openwrt-linux-uclibc-nm CC="mips-openwrt-linux-uclibc-gcc" GCC="mips-openwrt-linux-uclibc-gcc" CXX="mips-openwrt-linux-uclibc-g++" RANLIB=mips-openwrt-linux-uclibc-ranlib STRIP=mips-openwrt-linux-uclibc-strip OBJCOPY=mips-openwrt-linux-uclibc-objcopy OBJDUMP=mips-openwrt-linux-uclibc-objdump SIZE=mips-openwrt-linux-uclibc-size
make[3]: Entering directory `/media/linDATA/OpenWRT_dev/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/appweb-3.2.2-1'
build/make/Makefile.top:104: *** mixed implicit and normal rules.  Stop.
make[3]: Leaving directory `/media/linDATA/OpenWRT_dev/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/appweb-3.2.2-1'
make[2]: *** [/media/linDATA/OpenWRT_dev/trunk/build_dir/target-mips_r2_uClibc-0.9.33.2/appweb-3.2.2-1/.built] Error 2
make[2]: Leaving directory `/media/linDATA/OpenWRT_dev/trunk/feeds/packages/net/appweb'
make[1]: *** [package/feeds/packages/appweb/compile] Error 2
make[1]: Leaving directory `/media/linDATA/OpenWRT_dev/trunk'
make: *** [package/feeds/packages/appweb/compile] Error 2

Attachments (2)

001-fix-mixed-target.patch (636 bytes) - added by anonymous 6 years ago.
001-fix-mixed-target.2.patch (1.6 KB) - added by anonymous 6 years ago.
working patch for appwed

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by anonymous

comment:1 Changed 6 years ago by Jiri Pirko <jiri@…>

I have this similar problem on the latest trunk here. I'm able to test eventual patch.

comment:2 Changed 6 years ago by anonymous

After a long search i was able to fix this issue. First the appweb Makefile must be edited.
Add

$(call Build/Prepare/Default)

just after

tar xzf "$(DL_DIR)/$(PKG_SOURCE)" --strip-components 1 -C "$(PKG_BUILD_DIR)"

in the "package/feeds/packages/appweb/Makefile".
Then make a dir "package/feeds/packages/appweb/patches" and put in it the new patch file attached here.
After this it should compile well.

Changed 6 years ago by anonymous

working patch for appwed

comment:3 Changed 5 years ago by anonymous

Confirmed this on my build system. It seems it has to do with my version of make (3.82) that doesn't like this particular syntax in the Appweb makefile.

Putting the last patch attached above in the "package/feeds/packages/appweb/patches" directory fixes it for me and compiling won't fail anymore.

comment:4 Changed 5 years ago by anonymous

I tried to compile following the last instructions but compiling fail.
This is the log:

make[4]: Entering directory `/home/luca/data/projects/antitheft/openwrt/backfire/build_dir/target-mips_uClibc-0.9.30.1/appweb-3.2.2-1'

[Notice] Building Embedthis Appweb 3.2.2. For command details, use "make TRACE=1".

[Link] bin/makerom

/home/luca/data/projects/antitheft/openwrt/backfire/build_dir/target-mips_uClibc-0.9.30.1/appweb-3.2.2-1/lib/libmpr.so: undefined reference to `dlclose'
collect2: ld returned 1 exit status
bld: /usr/bin/cc failed

[DETAILS] bld "--exe" "../../bin/makerom" "--search" "--libs" "mpr" "makerom"

make[8]: * bin/makerom Error 255
make[7]: * [compileFirst] Error 2
make[6]:
* [compileDirs] Error 2
make[5]: * [compileDirs] Error 2
make[4]:
* [compile] Error 255

comment:5 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.